#2518 new defect

RTEMS 4.9 cannot be built with modern texinfo (includes a fix)

Reported by: Goetz Pfeiffer Owned by: Chris Johns
Priority: normal Milestone: 4.9.5
Component: unspecified Version: 4.9
Severity: normal Keywords: cannot build debian-7
Cc: Blocked By:
Blocking:

Description

Using the rtems source builder to build RTEMS 4.9 on a debian-7 linux system fails since some of the texinfo files in newlib-gcc and gcc are invalid for texinfo. This applies at least for texinfo version 6.0. This Report also contains a git patch for the git://git.rtems.org/rtems-tools.git repository to fix the problem.

Could somebody with write permissions please add these ("git apply [patchfile]") ?

Attachments (1)

0001-Bugfix-gcc-4.3.2-couldn-t-be-build-with-a-modern-tex.patch (4.5 KB) - added by Goetz Pfeiffer on Jan 12, 2016 at 9:10:26 AM.
Fix gcc-4.3.2 incompatibility with texinfo 6.0

Download all attachments as: .zip

Change History (2)

Changed on Jan 12, 2016 at 9:10:26 AM by Goetz Pfeiffer

Fix gcc-4.3.2 incompatibility with texinfo 6.0

comment:1 Changed on Aug 14, 2017 at 12:53:40 AM by Chris Johns

These tickets need funding to be fixed.

Note: See TracTickets for help on using tickets.