#2519 new defect

RSB cannot build RTEMS 4.9 (includes a fix)

Reported by: Goetz Pfeiffer Owned by: Chris Johns
Priority: normal Milestone: 4.9.5
Component: tool/rsb Version: 4.9
Severity: normal Keywords: RSB 4.9 resource builder
Cc: Blocked By:
Blocking:

Description

The RTEMS resource builder fails to build RTEMS 4.9 (verified on a linux debian-7 system). There are two problems:

  1. A misconfiguration in rtems/config/tools/rtems-gcc-4.3.2-newlib-1.16.0-1.cfg
  2. Incompability of texinfo files in gcc 4.3.2 with texinfo 6.0.

This report contains two patch files that would fix the problems. Note that
patch "rtems-4.9-gcc-4.3.2-bugfix.patch" relies on the patch of report #2518 to be appled to git://git.rtems.org/rtems-tools.git .

Attachments (2)

rtems-4.9-newlib-gcc-4.3.2-config-bugfix.patch (1.1 KB) - added by Goetz Pfeiffer on Jan 12, 2016 at 9:26:23 AM.
Fix misconfiguration in rtems/config/tools/rtems-gcc-4.3.2-newlib-1.16.0-1.cfg
rtems-4.9-gcc-4.3.2-bugfix.patch (994 bytes) - added by Goetz Pfeiffer on Jan 12, 2016 at 9:26:52 AM.
Use extra gcc patch from ticket #2518

Download all attachments as: .zip

Change History (3)

Changed on Jan 12, 2016 at 9:26:23 AM by Goetz Pfeiffer

Fix misconfiguration in rtems/config/tools/rtems-gcc-4.3.2-newlib-1.16.0-1.cfg

Changed on Jan 12, 2016 at 9:26:52 AM by Goetz Pfeiffer

Use extra gcc patch from ticket #2518

comment:1 Changed on Aug 14, 2017 at 12:53:40 AM by Chris Johns

These tickets need funding to be fixed.

Note: See TracTickets for help on using tickets.