#4401 closed enhancement (fixed)

rtems: Change rtems_scheduler_get_processor_set() status

Reported by: Sebastian Huber Owned by: Sebastian Huber
Priority: normal Milestone: 6.1
Component: rtems Version: 6
Severity: normal Keywords: qualification
Cc: Blocked By:
Blocking:

Description

In case the processor set is not large enough to contain the processor set of the scheduler return RTEMS_INVALID_SIZE instead of RTEMS_INVALID_NUMBER. This is more in line with other directives since the issue is related to the size of an object.

A similar change was done in #4393.

Change History (4)

comment:1 Changed on May 6, 2021 at 1:15:03 PM by Sebastian Huber <sebastian.huber@…>

Resolution: fixed
Status: assignedclosed

In 48898b3/rtems:

rtems: rtems_scheduler_get_processor_set() status

In case the processor set is not large enough to contain the processor
set owned by the scheduler return RTEMS_INVALID_SIZE instead of
RTEMS_INVALID_NUMBER. This is more in line with other directives since
the issue is related to the size of an object.

Close #4401.

comment:2 Changed on May 7, 2021 at 6:09:35 AM by Sebastian Huber <sebastian.huber@…>

In 6822af7/rtems:

rtems: rtems_scheduler_get_processor_set() docs

Document changed error status.

Update #4401.

comment:3 Changed on May 7, 2021 at 6:19:33 AM by Sebastian Huber <sebastian.huber@…>

In e8cd4d3/rtems-docs:

c-user: rtems_scheduler_get_processor_set()

Document changed error status.

Update #4401.

comment:4 Changed on Jun 23, 2021 at 7:07:55 AM by Sebastian Huber

Keywords: qualification added
Note: See TracTickets for help on using tickets.