#4393 closed enhancement (fixed)

rtems: Change rtems_task_get_affinity() status

Reported by: Sebastian Huber Owned by: Sebastian Huber
Priority: normal Milestone: 6.1
Component: rtems Version: 6
Severity: normal Keywords: qualification
Cc: Blocked By:
Blocking:

Description

In case the processor set is not large enough to contain the processor affinity set of the task return RTEMS_INVALID_SIZE instead of RTEMS_INVALID_NUMBER. This is more in line with other directives since the issue is related to the size of an object.

Change History (2)

comment:1 Changed on 04/27/21 at 17:53:19 by Sebastian Huber <sebastian.huber@…>

Resolution: fixed
Status: assignedclosed

In 4b7c77b/rtems:

rtems: Change rtems_task_get_affinity() status

In case the processor set is not large enough to contain the processor
affinity set of the task return RTEMS_INVALID_SIZE instead of
RTEMS_INVALID_NUMBER. This is more in line with other directives since
the issue is related to the size of an object.

Close #4393.

comment:2 Changed on 06/23/21 at 07:07:55 by Sebastian Huber

Keywords: qualification added
Note: See TracTickets for help on using tickets.