#3831 closed defect (fixed)

Duplicate description of Tiers and Rules

Reported by: Joel Sherrill Owned by: Chris Johns
Priority: normal Milestone: 5.1
Component: doc Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

I think https://docs.rtems.org/branches/master/user/hardware/tiers.html is intended to be the real site of this information. However, https://devel.rtems.org/wiki/Developer/Architectures also describes the tiers rules with slightly different language.

I think the Wiki page can be reviewed and removed. But any references and sub-pages should be dealt with at the same time. https://devel.rtems.org/search?q=Developer%2FArchitectures&noquickjump=1&wiki=on shows two sub-pages to deal with:

This would eliminate a few pages and a point of duplication for a very important concept to the RTEMS Project.

Change History (6)

comment:1 Changed on Dec 4, 2019 at 1:26:37 PM by Sebastian Huber

I removed both ARM pages. The information was out of date since a couple of years.

comment:2 Changed on Dec 4, 2019 at 1:28:09 PM by Joel Sherrill

Thanks. I tripped across this doing the FSW slides. Were there links to these pages?

comment:3 Changed on Dec 4, 2019 at 1:31:34 PM by Sebastian Huber

How can we figure out if there are links?

The Developer/Architectures? looks like content which should be synchronized with the user manual and then get deleted.

comment:4 Changed on Dec 5, 2019 at 2:34:51 PM by Christian Mauderer

I would interpret the two sources slightly different:

  1. The manual (at docs.rtems.org) sounds like tires are a per commit property. That would mean that every published result tells "The BSP has this Tire on commit/release xyz". That seems like a sane approach.
  2. The wiki on the other hand tells something about "all commits". That's a quite inaccurate description. It doesn't tell what the first commit is. So in theory every commit since RTEMS exists has to build and work for that board. That is just is impossible. Beneath that the wiki allows simulator results in tire 1. So it's not entirely clear what the difference to tire 2 is.

I would vote for dropping the inaccurate description in the wiki in favor of the more accurate one in the manual.

comment:5 Changed on Dec 12, 2019 at 5:00:11 PM by Joel Sherrill <joel@…>

Resolution: fixed
Status: assignedclosed

In 01be513/rtems-docs:

user/hardware/tiers.rst: Merge info from Wiki.

Tiers had a write up on the Wiki which was similar but different.
Merged content from the Wiki which allows the Wiki page to be
deleted.

closes #3831.

comment:6 Changed on Dec 12, 2019 at 5:29:08 PM by Joel Sherrill

Wiki page deleted.

Sebastian: I searched for the Wiki page name in only wiki pages. Maybe there is another way but that confirmed it had no refernces.

Note: See TracTickets for help on using tickets.