#4387 closed defect (fixed)

covoar marks taken/not taken incorrectly for AArch64

Reported by: Alex White Owned by: Alex White
Priority: normal Milestone: 6.1
Component: tool Version: 6
Severity: normal Keywords: coverage, covoar
Cc: Blocked By:
Blocking:

Description

The AArch64 annotated assembly produced by covoar reveals that branches that are never taken are marked "ALWAYS TAKEN" and branches that are always taken are marked "NEVER TAKEN".

It appears that this is caused by incorrect return values in TargetBase::qemuTakenBit() and TargetBase::qemuNotTakenBit(). These methods should be overridden in Target_aarch64 so that the return values are switched.

Change History (2)

comment:1 Changed on Apr 16, 2021 at 6:11:12 PM by Alex White

Owner: set to Alex White
Status: newaccepted

comment:2 Changed on Apr 16, 2021 at 10:29:05 PM by Alex White <alex.white@…>

Resolution: fixed
Status: acceptedclosed

In 0c4884a/rtems-tools:

covoar/Target_aarch64: Swap QEMU taken/not taken bits

This overrides the TargetBase behavior to allow branches to be marked
correctly as either taken or not taken.

Closes #4387

Note: See TracTickets for help on using tickets.