#3777 closed defect (fixed)

libdl object unload debugger delete support is broken

Reported by: Chris Johns Owned by: Chris Johns
Priority: high Milestone: 5.1
Component: lib/dl Version: 5
Severity: critical Keywords:
Cc: Blocked By:
Blocking:

Description

The test dl09.exe crashes on BBB, Zedboard, and RPi2 but runs on arm qemu and psim. The issue is uncovered by the heap protection support in free() where the free block has been touched.

It turns out _rtld_linkmap_delete() list code is broken. The object module's block should not be walked to the end.

Change History (1)

comment:1 Changed on Aug 11, 2019 at 10:53:16 PM by Chris Johns <chrisj@…>

Resolution: fixed
Status: assignedclosed

In 9cb19ded/rtems:

libdl/debugger: Fix the broken list delete when unloading an object module.

Closes #3777

Note: See TracTickets for help on using tickets.