#3391 closed defect (fixed)

or1k TLS and GCC version

Reported by: Joel Sherrill Owned by: Joel Sherrill <joel@…>
Priority: normal Milestone: Indefinite
Component: arch/or1k Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

As of today, or1k is using gcc 4.9.x and it does not compile the TLS tests because it doesn't have the thread_local keyword.

This ticket is to track that I have disabled the tls tests for the or1k BSP and they need to be re-enabled when the or1k gcc is updated.

Change History (1)

comment:1 Changed on Nov 29, 2018 at 10:46:48 PM by Joel Sherrill <joel@…>

Owner: set to Joel Sherrill <joel@…>
Resolution: fixed
Status: newclosed

In e447d4c0/rtems:

generic_or1k-testsuite.tcfg: Enable sptls01 now that GCC is from FSF master

Closes #3391.

Note: See TracTickets for help on using tickets.