#3187 closed defect (fixed)

smptests/Makefile.am Issues

Reported by: Joel Sherrill Owned by: Sebastian Huber
Priority: normal Milestone: 5.1
Component: build Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

There appear to be two issues in smptests/Makefile.am:

  1. smppsxaffinity0[12] are listed twice. This causes a warning. I am unsure if they should always be built or only when POSIX is enabled.
  1. smppsxmutex01 is listed in the "HAS_POSIX" section. Aren't POSIX mutexes always on now so this test should not be inside the conditional?

Change History (5)

comment:1 Changed on Oct 12, 2017 at 6:32:53 PM by Joel Sherrill

Component: adminbuild
Owner: set to Sebastian Huber
Status: newassigned

comment:2 Changed on Oct 13, 2017 at 4:55:00 AM by Sebastian Huber

It is a bit work left to enable the POSIX tests by default, e.g. a lot of them use pthread_create().

comment:3 Changed on Oct 25, 2017 at 5:59:02 AM by Sebastian Huber

The 2. is a duplicate of #2514.

comment:4 Changed on Oct 25, 2017 at 5:59:40 AM by Sebastian Huber <sebastian.huber@…>

Resolution: fixed
Status: assignedclosed

In e3ef14b/rtems:

smptests: Remove duplicate Makefile targets

Close #3187.

comment:5 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.