#2863 closed enhancement (duplicate)

Update POSIX 1003.1 Compliance Guide for ReST

Reported by: Joel Sherrill Owned by: Joel Sherrill
Priority: normal Milestone: 5.1
Component: doc Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

The POSIX 1003.1 Compliance Guide should be auto-generated from a spreadsheet into the ReST format. My vague recollection is that we used shell scripts to do this for texinfo output.

I will have to decipher what we used to do and define a new procedure.

This impacts 4.11 and newer. One issue is having correct information for what methods are present on a branch. The FACE Conformance Test Suite can be used for ~800 of the methods.

Change History (5)

comment:1 Changed on May 11, 2017 at 7:31:02 AM by Sebastian Huber

Milestone: 4.124.12.0

comment:2 Changed on Aug 14, 2017 at 12:14:07 AM by Chris Johns

Version: 4.114.12

What is the priority on this work and will be it available for the 4.12.0 milestone?

comment:3 Changed on Oct 10, 2017 at 6:06:29 AM by Sebastian Huber

Component: Documentationdoc

comment:4 Changed on Oct 11, 2017 at 11:45:37 PM by Joel Sherrill

Resolution: duplicate
Status: newclosed

This is a duplicate of #3177

comment:5 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.