#2133 closed defect (fixed)

<rtems/score/basedefs.h> superfluously includes <string.h>

Reported by: Sebastian Huber Owned by: Sebastian Huber
Priority: normal Milestone: 5.1
Component: score Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description (last modified by Chris Johns)

In older RTEMS versions <rtems.h> provided <string.h> indirectly. The include
of <string.h> was added to not break application source files that relied on
this accidentally.

We may remove this include in the future.

Change History (18)

comment:1 Changed on Jul 23, 2013 at 10:28:30 AM by Sebastian Huber

In older RTEMS versions <rtems.h> provided <string.h> indirectly. The include
of <string.h> was added to not break application source files that relied on
this accidentally.

We may remove this include in the future.

comment:2 Changed on Nov 23, 2014 at 4:45:56 PM by Joel Sherrill

Description: modified (diff)

Can this be closed? The ticket is a warning about a change to basedefs.h and the comment makes no sense.

comment:3 Changed on Nov 24, 2014 at 6:58:28 PM by Gedare Bloom

Version: HEAD4.11

Replace Version=HEAD with Version=4.11 for the tickets with Milestone >= 4.11

comment:4 Changed on Nov 27, 2014 at 1:50:45 PM by Sebastian Huber

Milestone: 4.115.0

comment:5 Changed on Nov 27, 2014 at 2:47:36 PM by Joel Sherrill

Out of curiosity, why shouldn't we just remove these includes now? There is no way to warn a user at compile time that they will be impacted. All we are doing is delaying the inevitable random number of users who are impacted. Hopefully that number is higher in the future than now.

My proposal is:

+ make a announcement to users@ and devel@ that these includes were removed and any

code that unintentionally depended on them will have compile errors or warnings.
This will serve as a hit in Google.

+ Remove it and see what tests break. Make sure the commits for those issues include

enough information in the log so Google will see those as related.

Break and move forward.

comment:6 in reply to:  5 Changed on Nov 27, 2014 at 2:49:14 PM by Amar Takhar

Replying to joel.sherrill:

Out of curiosity, why shouldn't we just remove these includes now? There is no way to warn a user at compile time that they will be impacted. All we are doing is delaying the inevitable random number of users who are impacted. Hopefully that number is higher in the future than now.

All of these are moving in 5.0 anyway why bother moving it now when it works? I don't disagree with your reasoning but closing milestone:4.11 would be nice!

comment:7 Changed on Nov 27, 2014 at 3:02:35 PM by Sebastian Huber

At the time I created the *impl.h header files, a lot of stuff broke due to the now missing indirect include. I guess this is also true for application code. Especially <string.h>. Maybe this include is a feature not a bug.

comment:8 Changed on Nov 27, 2014 at 3:32:18 PM by Joel Sherrill

I agree on closing milestone 4.11 but this isn't the long pole in the tent. If we want to just get this behind us, let's do it. No point putting it off.

comment:9 Changed on Nov 27, 2014 at 3:45:08 PM by Sebastian Huber

We still have the option to set this to WONTFIX and close it forever.

comment:10 Changed on Aug 13, 2017 at 11:55:42 PM by Chris Johns

Description: modified (diff)
Milestone: 5.04.11.3

Please fix or close this ticket? Thanks.

comment:11 Changed on Aug 24, 2017 at 10:47:31 AM by Sebastian Huber

Owner: changed from Joel Sherrill to Sebastian Huber
Status: newaccepted

comment:12 Changed on Aug 24, 2017 at 4:15:12 PM by Joel Sherrill

I don't think the milestone should be 4.11.3. At this point, this would break the contract for users on a release branch. I think the milestone should be 4.12 and this fixed.

comment:13 Changed on Aug 25, 2017 at 6:32:41 AM by Sebastian Huber

Milestone: 4.11.34.12.0
Version: 4.11

comment:14 Changed on Aug 25, 2017 at 10:53:56 AM by Sebastian Huber <sebastian.huber@…>

In b2ed712/rtems:

Include missing <string.h>

Update #2133.

comment:15 Changed on Aug 25, 2017 at 10:54:35 AM by Sebastian Huber <sebastian.huber@…>

In 76b9c31/rtems:

libpci: Use calloc()

Update #2133.

comment:16 Changed on Aug 25, 2017 at 10:55:11 AM by Sebastian Huber <sebastian.huber@…>

Resolution: fixed
Status: acceptedclosed

In 163ff8e/rtems:

score: Remove <string.h> include from basedefs.h

Close #2133.

comment:17 Changed on Aug 25, 2017 at 12:24:08 PM by Sebastian Huber <sebastian.huber@…>

In 666a568/rtems-libbsd:

Include missing <string.h> and <limits.h>

Fix warnings.

Update #2132.
Update #2133.

comment:18 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.