#2123 closed defect (worksforme)

Could RSB automatically install autoconf/automake if the versions are too low?

Reported by: cynt6007 Owned by: Chris Johns
Priority: normal Milestone: 4.11
Component: tool/rsb Version: 4.10
Severity: major Keywords:
Cc: Blocked By:
Blocking:

Description

Could RSB run an automake and autoconf check at the beginning of the process when building 4.10.x/4.11, and automatically add building autoconf and/or automake to the build set if the version is too low?

My assessment is this is only necessary for RTEMS versions 4.10.x and 4.11.0, because earlier versions of RTEMS would not need to check for autotools, our most obsolete supported host, Debian 5 (Lenny), has prepackaged autoconf-2.61 and automake-1.10, see: http://archive.debian.net/lenny/devel/
and newer versions of RTEMS may be shipping with the build-system software.

The versions for the Debian/Lenny? distro are: automake-1.10 and autoconf-2.61 while rtems-4.10.x requires automake-1.11.1 and autoconf-2.68.

Change History (5)

comment:1 Changed on May 11, 2013 at 3:55:14 PM by cynt6007

Severity: enhancementmajor

comment:2 Changed on May 13, 2013 at 11:06:29 PM by cynt6007

Resolution: worksforme
Status: newclosed

comment:3 Changed on May 13, 2013 at 11:44:52 PM by Chris Johns

Worked around.

comment:4 Changed on Nov 22, 2014 at 12:29:09 PM by Gedare Bloom

Component: Minimum Version ChecksRSB
Milestone: 4.11

comment:5 Changed on Oct 10, 2017 at 6:11:36 AM by Sebastian Huber

Component: Minimum Version ChecksRSB
Note: See TracTickets for help on using tickets.