#1969 closed defect (worksforme)

lpc2362 does not build

Reported by: Joel Sherrill Owned by: thomas.doerfler
Priority: normal Milestone: 4.11
Component: bsps Version: 4.11
Severity: normal Keywords:
Cc: ralf.corsepius@…, jennifer.averett@…, thomas.doerfler@…, sebastian.huber@… Blocked By:
Blocking:

Description

/users/joel/test-gcc/rtems/configure \

--target=arm-rtems4.11 --enable-multilib \
--enable-ada --enable-posix --enable-networking \
--enable-maintainer-mode --disable-tests \
--prefix=/users/joel/test-gcc/install-svn

make

Ends with...

/users/joel/test-gcc/rtems/c/src/lib/libbsp/arm/lpc24xx/console/console-config.c:110:18: error: 'LPC24XX_PCLKDIV' undeclared here (not in a function)
gmake[6]: * [libbsp_a-console-config.o] Error 1
gmake[6]: Leaving directory `/home2/joel/build/b-arm-multilib/arm-rtems4.11/c/lpc2362/lib/libbsp/arm/lpc24xx'

It could be caused by Jennifer's console changes but I don't think so since LPC24XX_PCLKDIV isn't in the bspopts.h like I would expect.

Change History (6)

comment:1 Changed on Nov 23, 2011 at 9:19:01 PM by Joel Sherrill

Cc: thomas.doerfler added
Owner: changed from Joel Sherrill to thomas.doerfler

comment:2 Changed on Nov 23, 2011 at 9:21:42 PM by Joel Sherrill

Cc: Jennifer Averett added

comment:3 Changed on Nov 30, 2011 at 3:13:23 AM by Ralf Corsepius

Cc: Ralf Corsepius added

comment:4 Changed on Dec 12, 2011 at 6:29:28 AM by Sebastian Huber

Cc: Sebastian Huber added

comment:5 Changed on Feb 2, 2012 at 6:35:39 PM by Joel Sherrill

Resolution: worksforme
Status: newclosed

Closing. Revisit if an issue.

comment:6 Changed on Nov 24, 2014 at 6:58:28 PM by Gedare Bloom

Version: HEAD4.11

Replace Version=HEAD with Version=4.11 for the tickets with Milestone >= 4.11

Note: See TracTickets for help on using tickets.