#1441 closed defect (fixed)

tcgetprgrp should be tcgetpgrp

Reported by: Ralf Corsepius Owned by: Ralf Corsepius
Priority: normal Milestone: 4.10
Component: score Version: 4.8
Severity: minor Keywords:
Cc: joel.sherrill@… Blocked By:
Blocking:

Description

All active versions of RTEMS provide a function called tcgetprgrp()
in cpukit/src/tcgetprgrp.c.

AFAIS, this is nasty mis-namer. At least I can't find any trace of a function called "tcgetprgrp" in POSIX, other OS's manpages nor anywhere else.
Googling only returns references to RTEMS.

That said, I think this "tcgetprgrp" was meant to be POSIX's "tcgetpgrp"
(Note: tcgetPRgrp vs. tcgetPgrp), a function which currently seems to be missing in RTEMS.

Therefore, I am going to

  • rename cpukit/src/tcgetprgrp.c into cpukit/src/tcgetpgrp.c

and

  • rename the function tcgetprgrp into tcgetpgrp

Change History (3)

comment:1 Changed on Sep 15, 2009 at 4:19:17 AM by Ralf Corsepius

Cc: Joel Sherrill added

comment:2 Changed on Sep 15, 2009 at 4:20:14 AM by Ralf Corsepius

Summary: tcgetpgrp should be tcgetpgrptcgetprgrp should be tcgetpgrp

comment:3 Changed on Sep 15, 2009 at 5:04:48 AM by Ralf Corsepius

Resolution: fixed
Status: newclosed

Changes applied to rtems-4-8-branch, rtems-4-9-branch and CVS-HEAD.

Note: See TracTickets for help on using tickets.