wiki:Developer/Eclipse/Plugin

Version 24 (modified by Sebastian Huber, on Dec 10, 2014 at 8:42:27 AM) (diff)

Fix link

RTEMS Eclipse Plug-in

Introduction

This page describes how to setup and use the RTEMS Eclipse Plug-in. This plug-in extends CDT and all features of a full-fledged Eclipse/CDT IDE with an ordinary GNU toolchain are available. The GDB based debug support works also. Supported platforms are: Cygwin, MinGW, MacOS X and UNIX. Every RTEMS target architecture and BSP that provides the standard Makefiles is supported. These are at least the ones managed by the RTEMS repository from OAR.

Starting Point

You should be able to build a simple Hello, World'' application for your BSP with the standard Makefiles.

Eclipse Installation

The current plug-in version works with the Galileo release of Eclipse and CDT version 6. Other releases may work but are not tested. If you have not yet installed Eclipse simply choose the package Eclipse IDE for C/C++ Developers. An existing Eclipse installation needs a recent CDT plug-in (version 6 is recommended). The Eclipse IDE for C/C++ Developers already contains all required plug-ins.

If on Fedora, then you will want to load the eclipse-cdt RPM.

Plug-In Installation

You can install the plug-in via the standard Eclipse infrastucture. Simply add https://ftp.rtems.org/pub/rtems/eclipse/updates/ to the software update sites (Help > Install New Software...).

No image "repi-install.jpg" attached to Developer/Eclipse/Plugin

Plug-In Setup

After the plug-in installation you should setup the preferences (Window > Preferences).

No image "repi-setup.jpg" attached to Developer/Eclipse/Plugin

Base path: is the path to the RTEMS installed toolchain

BSP path: is the path to the RTEMS installed BSP Makefile.inc

  1. Ensure that RTEMS was installed
  2. Go to the PREFIX directory (the standard was /opt/rtems-4.11 new standard will be /home/user/development/rtems/4.11)

Find the Makefile.inc

/home/user/development/rtems/4.11$ find -name Makefile.inc

./sparc-rtems4.11/leon3/Makefile.inc ./sparc-rtems4.11/sis/Makefile.inc

Navigate to the /home/user/development/rtems/4.11/sparc-rtems4.11/sis when selecting a BSP path

Project Creation

Switch to the C/C++ Perpective (Window > Open Perspective > Other > C/C++ Perpective). You can now create a new C Project or C++ Project (File > New > C Project or File > New > C++ Project) and follow the wizard. You can create projects for RTEMS executables and static libraries. A Hello, World'' template is also available.

No image "repi-project.jpg" attached to Developer/Eclipse/Plugin

Project Properties

You can change the RTEMS specific project properties like RTEMS base installation path and board support package path via the standard properties dialog (Project > Properties) and with the project wizard.

No image "org-rtems-cdt-props.jpg" attached to Developer/Eclipse/Plugin

Trouble Shooting

General

Consult the problems view (Window > Show View > Problems), if something works not like expected. Errors like below indicate that the paths in the RTEMS preferences and properties are not correct.

No image "org-rtems-cdt-problem-0.jpg" attached to Developer/Eclipse/Plugin No image "org-rtems-cdt-problem-1.jpg" attached to Developer/Eclipse/Plugin

Cross-references not Working

Rebuild the index (Project Context Menu > Index > Rebuild).

Clear Built-in Include Paths

In the Discovery Options tab (Project Context Menu > Properties > C/C++ Build > Discovery Options) execute the Clear request for each tool in the tools box.

Attachments (6)

Download all attachments as: .zip