#835 closed defect (fixed)

VME interrupts on mvme2100 dont work

Reported by: strauman Owned by: Joel Sherrill
Priority: highest Milestone: 2
Component: bsps Version: 4.6
Severity: critical Keywords:
Cc: bugs@…, strauman@… Blocked By:
Blocking:

Description

default universe interrupt manager initialization (shared/vme/vmeconfig.c) is wrong (correct only for mvme2300).
Unfortunately, fixing this the right way requires a modification of the universe driver and updating all BSPs that use it :-(.

Release:
4.6

Change History (1)

comment:1 Changed on Nov 4, 2005 at 7:25:42 AM by strauman

Status: assignedclosed

State-Changed-From-To: open->closed
State-Changed-Why: several fixes to PCI and VME code have been applied to the
CVS head. I don't want to merge these to the 4.6 branch
since they are too invasive.
I have tested

VME interrupts [loopback IRQs]
VME address probing
VME access (master & slave)
PCI interrupts [PMC ethernet card]
PCI access [PMC ethernet card]

on MVME2300 MVME2100 and MVME5500 boards.

Note: See TracTickets for help on using tickets.