Notice: We have migrated to GitLab launching 2024-05-01 see here: https://gitlab.rtems.org/

#559 closed defect (fixed)

newlib-1.11.0-rtems-20030605.diff is broken

Reported by: Ralf Corsepius Owned by: Joel Sherrill
Priority: highest Milestone: 4.9
Component: tool Version: 4.6
Severity: critical Keywords:
Cc: bugs@…, ralf.corsepius@… Blocked By:
Blocking:

Description

The newlib-1.11.0-rtems-20030605.diff you had used for your rtems-4.6-i960-rtems-gcc-3.2.3*rpms contains autom4te.cache.

=> Parts of this patch had been generated by autoconf >= 2.50
newlib uses autoconf < 2.50
=> autom4te.cache's should never be shipped.

I recall we had this issue before (Probably in June 2003).
Seems to me that you are using outdated, and known to be broken patches for the gcc-rpms.

This issue probably doesn't have any impact on functionality of gcc*newlib, but is not necessarily an evidence of quality. IMO, there should not be any room for it in a _release_ that has gone through >3 years of preparations.

Release:
RTEMS-4.6

Change History (2)

comment:1 Changed on 01/20/05 at 16:14:52 by Joel Sherrill

Status: assignedwaiting

comment:2 Changed on 05/07/08 at 20:21:57 by Joel Sherrill

Milestone: 4.9
rep_platform: All
Resolution: fixed
Status: assignedclosed

Does not apply to a currently supported version of RTEMS and Ralf has to have addressed this since gcc 3.2.3. :-D

Note: See TracTickets for help on using tickets.