#4191 new defect

MSYS2 build error

Reported by: rmueller Owned by:
Priority: normal Milestone:
Component: admin Version: 6
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

I think this is an issue which has happended before:

https://devel.rtems.org/ticket/3783

However, its happening again for me:

When running the RTEMS RSB to install the toolsuite:

../source-builder/sb-set-builder --prefix=$RTEMS_INST 6/rtems-arm

RTEMS Source Builder - Set Builder, 6 (31dd1ab4424e modified)
Build Set: 6/rtems-arm
Build Set: 6/rtems-autotools.bset
Build Set: 6/rtems-autotools-internal.bset
config: tools/rtems-autoconf-2.69-1.cfg
...
reporting: devel/expat-2.1.0-1.cfg -> expat-2.1.0-x86_64-w64-mingw32-1.xml
config: tools/rtems-gdb-head.cfg
error: shell macro failed: sh -c "/mingw64/bin/python2-config --ldflags | awk 'BEGIN{FS=\" \"}/python/{for(i=1;i<NF;++i)if(match($i,\".*lpython.*\")) print \"lib\"substr($i,3)\"*\";}'": 1: awk: cmd. line:1: BEGIN{FS=" "}/python/{for(i=1;i<NF;++i)if(match(,".*lpython.*")) print "lib"substr(,3)"*";}
awk: cmd. line:1: syntax error
awk: cmd. line:1: BEGIN{FS=" "}/python/{for(i=1;i<NF;++i)if(match(,".*lpython.*")) print "lib"substr(,3)"*";}
awk: cmd. line:1:
1 is invalid as number of arguments for match
close failed in file object destructor:
sys.excepthook is missing
lost sys.stderr
Build FAILED
Build Set: Time 0:07:20.475176
Build FAILED

Anyone have an idea what might cause this? I am using MinGW64 like recommended in the QuickStart? guide

Change History (2)

comment:2 Changed on Nov 27, 2020 at 10:00:44 AM by rmueller

Actually, this is another error. It's propably because $i yields no value.
But I don't know from where this shell command was called and why $i is empty.

Note: See TracTickets for help on using tickets.