#413 closed defect (fixed)

Can't link EPICS executables for MVME167

Reported by: Eric Norum Owned by: Joel Sherrill
Priority: high Milestone: 2
Component: tool Version: 4.5
Severity: critical Keywords:
Cc: bugs@… Blocked By:
Blocking:

Description

I get the following strange behaviour when I try to link anything related to EPICS:

/opt/rtems/lib/gcc-lib/m68k-rtems/3.2.3/../../../../m68k-rtems/bin/ld: warning: no memory region specified for section `.data.rel.local'
/opt/rtems/lib/gcc-lib/m68k-rtems/3.2.3/../../../../m68k-rtems/bin/ld: warning: no memory region specified for section `.got'
/opt/rtems/lib/gcc-lib/m68k-rtems/3.2.3/../../../../m68k-rtems/bin/ld: warning: no memory region specified for section `.got.plt'
/opt/rtems/lib/gcc-lib/m68k-rtems/3.2.3/../../../../m68k-rtems/bin/ld: warning: no memory region specified for section `.data.rel.ro.local'
/opt/rtems/lib/gcc-lib/m68k-rtems/3.2.3/../../../../m68k-rtems/bin/ld: section .data.rel.local [00000000 -> 000003a7] overlaps section .text [00000000 -> 0005297f]
/opt/rtems/lib/gcc-lib/m68k-rtems/3.2.3/../../../../m68k-rtems/bin/ld: section .got [000003a8 -> 000006c3] overlaps section .text [00000000 -> 0005297f]
/opt/rtems/lib/gcc-lib/m68k-rtems/3.2.3/../../../../m68k-rtems/bin/ld: section .got.plt [000006c4 -> 000006cf] overlaps section .text [00000000 -> 0005297f]
/opt/rtems/lib/gcc-lib/m68k-rtems/3.2.3/../../../../m68k-rtems/bin/ld: section .data.rel.ro.local [000006d0 -> 0000079b] overlaps section .text [00000000 -> 0005297f]
collect2: ld returned 1 exit status

I did an m68k-rtems-objdump --section-headers of every .o and .a file I could think of, but none of them have any of those sections (.got, .got.plt, etc.). Where could these be coming from? I can run the RTEMS samples, but nothing related to EPICS.
Things that come to mind are:
1) EPICS uses a *lot* of C++ stuff. Is this some weird exception handler stuff? But the problem doesn't show up for RTEMS-pc386 so that seems unlikely to me.
2) The executables are a lot bigger than the RTEMS samples.

Release:
RTEMS-4.5

Environment:
Building on linux or darwin for RTEMS MVME167 BSP.
GCC=gcc-3.2.3
BINUTILS=binutils-2.13.2.1
NEWLIB=newlib-1.11.0
GCCDIFF=20030507a
NEWLIBDIFF=20030507
rtems-4.6.0pre2 (with some minor changes to work with vxWorks boot proms)

Change History (1)

comment:1 Changed on Jun 2, 2003 at 2:47:07 PM by Joel Sherrill

Status: assignedclosed

State-Changed-From-To: open->closed
State-Changed-Why: Problem was on EPICS side.

Note: See TracTickets for help on using tickets.