#4117 closed defect (fixed)

lpc1768_mbed_ahb_ram_eth sp01 and others fail to link

Reported by: Joel Sherrill Owned by: Sebastian Huber
Priority: normal Milestone: 6.1
Component: arch/arm Version: 6
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

This fails on both waf and autoconf. This is troubling because the test is sp01 which should build and link.

Did not check if this also applies to 5 branch.

../rtems/configure --target=arm-rtems6 --enable-rtemsbsp=lpc1768_mbed_ahb_ram_eth --prefix=/home/joel/rtems-cron-6/tools/6/bsp-install --disable-networking --enable-posix --disable-smp --disable-multiprocessing --disable-rtems-debug --disable-profiling --enable-tests --enable-cxx --enable-maintainer-mode

Fails with:

arm-rtems6-gcc  -mthumb -mcpu=cortex-m3 -O2 -ggdb3 -ffunction-sections -fdata-sections -Wall -Wmissing-prototypes -Wimplicit-function-declaration -Wstrict-prototypes -Wnested-externs -B./../../lib/libbsp/arm/lpc176x -B/home/joel/rtems-cron-6/rtems/bsps/arm/lpc176x/start -specs bsp_specs -qrtems -L./../../cpukit -L/home/joel/rtems-cron-6/rtems/bsps/arm/shared/start -Wl,--wrap=printf -Wl,--wrap=puts -Wl,--wrap=putchar -Wl,--gc-sections -o sp01.exe sp01/sp01-init.o sp01/sp01-task1.o ./../../lib/libbsp/arm/lpc176x/librtemsbsp.a ./../../cpukit/librtemscpu.a ./../../cpukit/librtemstest.a 
/home/joel/rtems-cron-6/tools/6/lib/gcc/arm-rtems6/10.2.1/../../../../arm-rtems6/bin/ld: sp01.exe section `.bss' will not fit in region `RAM_AHB1'
/home/joel/rtems-cron-6/tools/6/lib/gcc/arm-rtems6/10.2.1/../../../../arm-rtems6/bin/ld: region `RAM_AHB1' overflowed by 2324 bytes
collect2: error: ld returned 1 exit status
gmake[5]: *** [sp01.exe] Error 1

Change History (4)

comment:1 Changed on 10/02/20 at 15:50:49 by Joel Sherrill

Owner: set to Sebastian Huber
Status: newassigned

comment:2 Changed on 10/02/20 at 15:52:59 by Sebastian Huber

Are you sure it fails with waf?

spec/build/bsps/arm/lpc176x/tstlpc1768mbedahbrameth.yml: sp01: exclude

comment:3 Changed on 10/02/20 at 16:39:29 by Joel Sherrill

Because waf uses the same build tree, I can't reproduce the waf build until the complete sweep finishes. It is a lost feature not to have the ability to have the build tree vary from build to build. :(

Anyway, this is what I have in the build log. Maybe you can reproduce more:

 grep FAILED all-bsps-log.txt | grep lpc1768_mbed_ahb_ram_eth
FAILED (2)  autoconf build of arm lpc1768_mbed_ahb_ram_eth (NOSMP/NOMP/DEBUG/PROFILE)
FAILED (1)  waf build of arm lpc1768_mbed_ahb_ram_eth (NOSMP/NOMP/DEBUG/PROFILE)
FAILED (2)  autoconf build of arm lpc1768_mbed_ahb_ram_eth (NOSMP/NOMP/DEBUG/NOPROFILE)
FAILED (1)  waf build of arm lpc1768_mbed_ahb_ram_eth (NOSMP/NOMP/DEBUG/NOPROFILE)
FAILED (2)  autoconf build of arm lpc1768_mbed_ahb_ram_eth (NOSMP/NOMP/NODEBUG/PROFILE)
FAILED (1)  waf build of arm lpc1768_mbed_ahb_ram_eth (NOSMP/NOMP/NODEBUG/PROFILE)
FAILED (2)  autoconf build of arm lpc1768_mbed_ahb_ram_eth (NOSMP/NOMP/NODEBUG/NOPROFILE)
FAILED (1)  waf build of arm lpc1768_mbed_ahb_ram_eth (NOSMP/NOMP/NODEBUG/NOPROFILE)

Please go ahead and add sp01 to the tcfg so the builds can get closer to matching. There was also at least one other test that didn't fit into the memory. We must achieve parity before the switchover. Minor issues must be addressed in the autoconf side. Major ones we will work around (like the smp/mp option).

comment:4 Changed on 10/05/20 at 17:34:48 by Sebastian Huber <sebastian.huber@…>

Resolution: fixed
Status: assignedclosed

In a9995f1/rtems:

bsp/lpc176x: Fix memory map

Due to the static allocation of operating system resources the .bss section
needs more space than the .work section.

Close #4117.

Note: See TracTickets for help on using tickets.