#4112 closed defect (fixed)

rtems-tools waf is broken with python 3.8.2

Reported by: Chris Johns Owned by: Chris Johns
Priority: normal Milestone: 4.11.4
Component: tool Version: 4.11
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

$ ./waf distclean configure --prefix=$HOME/si/rtems/4.11
/home/johnsy/si/rtems/rt/wscript:140: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  elif host is not 'native':
Traceback (most recent call last):
  File "/home/johnsy/si/rtems/rt/.waf3-1.8.19-b1fc8f7baef51bd2db4c2971909a568d/waflib/Node.py", line 312, in ant_iter
    raise StopIteration
StopIteration

Change History (1)

comment:1 Changed on 10/02/20 at 22:55:13 by Chris Johns <chrisj@…>

Resolution: fixed
Status: assignedclosed

In ee01850/rtems-tools:

waf: Update waf to the latest for better Python support

Closes #4112

Note: See TracTickets for help on using tickets.