Notice: We have migrated to GitLab launching 2024-05-01 see here: https://gitlab.rtems.org/

#3937 closed project (fixed)

Move content of bsp_specs to GCC

Reported by: Sebastian Huber Owned by: Sebastian Huber <sebastian.huber@…>
Priority: normal Milestone: 6.1
Component: tool/gcc Version: 6
Severity: normal Keywords: qualification
Cc: Blocked By:
Blocking: #3250

Description

Move content of the bsp_specs to GCC 10. Once this is done, update the tools and delete the bsp_specs.

On powerpc this means we have to move the content of rtems_crti.S to GCC. It may not be possible to back port this to GCC 10 and we may have to maintain this as a patch until GCC 11 is released.

Add support for nostartfiles and nodefaultlibs.

Attachments (2)

0001-RTEMS-Improve-GCC-specification.patch (2.9 KB) - added by Sebastian Huber on 04/07/20 at 07:35:34.
v2-0001-RTEMS-Improve-GCC-specification.patch (3.8 KB) - added by Sebastian Huber on 04/08/20 at 11:31:55.

Download all attachments as: .zip

Change History (15)

comment:1 Changed on 04/06/20 at 14:01:29 by Joel Sherrill

Dupe of #3250

comment:2 Changed on 04/06/20 at 14:01:59 by Sebastian Huber

Blocking: 3250 added

comment:3 in reply to:  1 Changed on 04/06/20 at 14:03:35 by Sebastian Huber

Replying to Joel Sherrill:

Dupe of #3250

I think this is a subtask.

comment:4 Changed on 04/06/20 at 14:49:54 by Sebastian Huber

Since -qrtems is not used to build GCC/Newlib. The rtems_crti.S could probably stay in RTEMS.

comment:5 Changed on 04/06/20 at 14:56:00 by Joel Sherrill

The only crti/crtn not provided by GCC are these for the PowerPC. They really should move. Whatever is being done is a hack left over from the days when we were unwilling to modify GCC.

$ find . -name rtems_crt*
./bsps/powerpc/shared/start/rtems_crti.S
./bsps/powerpc/shared/start/rtems_crtn.S

"Remove hacks left over from when we were unwilling to modify GCC" should be the name of this ticket. :)

comment:6 Changed on 04/06/20 at 14:58:38 by Sebastian Huber

I will try to get the RTEMS-only changes in GCC 10.2. This already requires release manager approval.

I am not sure if they are happy if I try to change standard powerpc files for RTEMS on a release branch.

Changed on 04/07/20 at 07:35:34 by Sebastian Huber

comment:7 Changed on 04/07/20 at 08:18:30 by Sebastian Huber <sebastian.huber@…>

In [changeset:"b69f54d51740810dc54a50662f5da4d4ba0ddd18/rtems-source-builder" b69f54d/rtems-source-builder]:

6: Update unstable RTEMS 6 tool chain

Update #3937.

Changed on 04/08/20 at 11:31:55 by Sebastian Huber

comment:8 Changed on 04/08/20 at 11:34:34 by Sebastian Huber <sebastian.huber@…>

In [changeset:"f6286ff1d3e8ec6e906f609f827c77cebd70b0d7/rtems-source-builder" f6286ff/rtems-source-builder]:

6: Update unstable RTEMS 6 tool chain

Update #3937.

comment:9 Changed on 01/22/21 at 09:52:53 by Sebastian Huber

It turned out that the GCC specs processing is a bit more complicated and the current approach doesn't work:

https://gcc.gnu.org/pipermail/gcc/2021-January/234728.html

comment:11 Changed on 01/26/21 at 05:38:50 by Sebastian Huber <sebastian.huber@…>

Owner: set to Sebastian Huber <sebastian.huber@…>
Resolution: fixed
Status: assignedclosed

In [changeset:"ade089253e70d75105a8311844f82f6d20cc30a8/rtems-source-builder" ade0892/rtems-source-builder]:

6: Update tool chain

Close #3937.

comment:12 Changed on 06/23/21 at 07:07:55 by Sebastian Huber

Keywords: qualification added

comment:13 Changed on 11/29/21 at 14:48:15 by Joel Sherrill <joel@…>

In [changeset:"dd70c81699a90ca48ae74980e8053b3c708ae6bc/rtems" dd70c81/rtems]:

bsp_specs: Delete last remnants of these.

Updates #3937.

Note: See TracTickets for help on using tickets.