#3919 closed defect (fixed)

RSB may not download source of pkconfig checked packages

Reported by: Chris Johns Owned by: Chris Johns
Priority: normal Milestone: 5.1
Component: tool/rsb Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

There are config files with the following:

#
# The GLib build instructions. We use 2.x.x Release 1.
#
%ifn %{pkgconfig check glib-2.0}
 %include %{_configdir}/glib-2-1.cfg
%endif

If the glib package is present the config file is not loaded and the source is not downloaded with the sb-get-source package. Change the config to:

#
# The GLib build instructions. We use 2.x.x Release 1.
#
%if !%{pkgconfig check glib-2.0} || %{defined _rsb_getting_source}
 %include %{_configdir}/glib-2-1.cfg
%endif

Change History (1)

comment:1 Changed on Mar 27, 2020 at 3:40:50 AM by Chris Johns <chrisj@…>

Resolution: fixed
Status: assignedclosed

In 9b7cdb7/rtems-source-builder:

bare: Fix pkgconfig checks and getting source.

  • If the package was installed the check does not build the package. This also meant getting the source failed.

Closes #3919

Note: See TracTickets for help on using tickets.