#3868 closed defect (fixed)

newlib links breaks mingw build

Reported by: Chris Johns Owned by: Chris Johns <chrisj@…>
Priority: high Milestone: 5.1
Component: tool/rsb Version: 5
Severity: blocker Keywords:
Cc: Blocked By:
Blocking:

Description

The following patch in newlib adds links and Windows does not have symlinks and it is emulated as copy. This complicates a bsdtar extraction of source ...

https://github.com/RTEMS/sourceware-mirror-newlib-cygwin/commit/cfc4955234828881145a20987c8a0a3cd373585c

I tried the -E option that was added to the RSB to extract the tar file a second time, this has worked with other tar files with symlinks however it does not work. I have no investigated why.

We need Windows building to make a release.

Note, this is in the tools/rsb component however is not an RSB bug. I need input on what the RSB needs to do to fix this issue if that is the path we take.

Change History (2)

comment:1 Changed on Feb 10, 2020 at 5:12:53 AM by Chris Johns

Hand testing with MSYS's tar (GNU tar) indicates links are handled with a suitable file copy.

It could be changing the RSB from bsdtar to tar may be a workable solution. The use of bsdtar seems to be before 2012 ...

https://git.rtems.org/rtems-source-builder/commit/?id=8f84a6b3a0bc7cbce09605f39329d3832682bf63

I remember there was a number of issues getting the source unpacked on Windows. I can build arm tools with tar.

comment:2 Changed on Feb 12, 2020 at 3:48:59 AM by Chris Johns <chrisj@…>

Owner: set to Chris Johns <chrisj@…>
Resolution: fixed
Status: newclosed

In 22135c9/rtems-source-builder:

windows: Use GNU tar to unpack source

  • The bsdtar command does not handle symlinks cleanly, GNU tar does

Closes #3868

Note: See TracTickets for help on using tickets.