#3803 closed defect (invalid)

RSB ssl context error fetching qemu patches

Reported by: Joel Sherrill Owned by: Chris Johns
Priority: normal Milestone: 5.1
Component: tool/rsb Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

It looks like there is a bug in the code that fetches source/patches. Jiri's site is a simple https:

making dir: /home/joel/rtems-work/rtems-source-builder/bare/patches
_url: https://gaisler.org/qemu/0001-LEON3-Add-emulation-of-AMBA-plug-play.patch -> /home/joel/rtems-work/rtems-source-builder/bare/patches/0001-LEON3-Add-emulation-of-AMBA-plug-play.patch
download: (full) https://gaisler.org/qemu/0001-LEON3-Add-emulation-of-AMBA-plug-play.patch -> patches/0001-LEON3-Add-emulation-of-AMBA-plug-play.patch
download: https://gaisler.org/qemu/0001-LEON3-Add-emulation-of-AMBA-plug-play.patch -> patches/0001-LEON3-Add-emulation-of-AMBA-plug-play.patch
download: no ssl context
download: https://gaisler.org/qemu/0001-LEON3-Add-emulation-of-AMBA-plug-play.patch: error: <urlopen error [Errno -2] Name or service not known>
error: downloading https://gaisler.org/qemu/0001-LEON3-Add-emulation-of-AMBA-plug-play.patch: all paths have failed, giving up

This is a build with the following script:

version=5
# variant="-couverture"

  time ../source-builder/sb-set-builder \
     --trace \
     --log=l-qemu.txt \
     --prefix=${HOME}/rtems-work/tools/${version} \
     devel/qemu${variant}

Change History (7)

comment:1 Changed on Oct 29, 2019 at 4:36:13 AM by Chris Johns

Are you sure it is a bug? I do not see the issue and have been downloading these files a lot over the last few days with the RSB.

comment:2 in reply to:  1 ; Changed on Oct 29, 2019 at 3:22:07 PM by Joel Sherrill

Replying to Chris Johns:

Are you sure it is a bug? I do not see the issue and have been downloading these files a lot over the last few days with the RSB.

Jiri has a patch which moves the patches to another server. This resolves it for me. But I am on Centos 7 and have tried Python 2.7 and 3.6. The patches load in a browser but don't fetch. Not sure what's up. I don't see this on any other package or patch.

comment:3 in reply to:  2 Changed on Oct 29, 2019 at 6:28:21 PM by Chris Johns

Replying to Joel Sherrill:

Jiri has a patch which moves the patches to another server. This resolves it for me.

But this does not find out if there is an issue. Lets not paper over the issue. Your debugging of this would help.

But I am on Centos 7 and have tried Python 2.7 and 3.6. The patches load in a browser but don't fetch. Not sure what's up. I don't see this on any other package or patch.

The code is ...

https://git.rtems.org/rtems-source-builder/tree/source-builder/sb/download.py#n367

Please add a raise here ...

https://git.rtems.org/rtems-source-builder/tree/source-builder/sb/download.py#n390

so the failure is printed. Even better if you could add code to better report the exception it would help long term. Python has great doco on exceptions and catching them.

comment:4 Changed on Oct 30, 2019 at 11:23:58 AM by Jiri Gaisler

The issue could have been caused by some temporary network problem to or in my server. How about if I attach the Leon3 Qemu patches to this ticket and modify RSB to fetch the patches from here ...? We used to do that for the sis/gdb patches and that worked OK.

comment:5 Changed on Oct 30, 2019 at 12:42:04 PM by Joel Sherrill

I tried this again yesterday and this morning and did not have issues. I am closing this as spurious network issues. We can always reopen it.

comment:6 in reply to:  4 Changed on Oct 30, 2019 at 8:50:27 PM by Chris Johns

Replying to Jiri Gaisler:

The issue could have been caused by some temporary network problem to or in my server. How about if I attach the Leon3 Qemu patches to this ticket and modify RSB to fetch the patches from here ...? We used to do that for the sis/gdb patches and that worked OK.

That is for Jiri to comment on. No one else is having problems and I think it is something local to your setup.

comment:7 Changed on Apr 5, 2020 at 4:56:23 AM by Gedare Bloom

Resolution: invalid
Status: assignedclosed
Note: See TracTickets for help on using tickets.