#3515 new defect

covoar failure while running for full testsuites/

Reported by: Vijay Kumar Banerjee Owned by:
Priority: normal Milestone:
Component: tool Version: 5
Severity: normal Keywords: coverage, testing
Cc: Joel Sherrill Blocked By:
Blocking:

Description

The covoar fails to complete for some symbol-sets with specific exes.
below I have noted all the sybol-sets that fail, along with the exe
that causes the failure.

It is observed that when covoar is run excluding these exes, it completes successfully .


following are the symbol-sets and the exes that fail.

  • posix
    • sptests/spmutex01.exe
    • fstests/fsclose01.exe
  • sapi
    • sptests/spversion01.exe
  • librfs
    • fstests/mrfs_fserror.exe
    • fstests/mrfs_fsrdwr.exe (all fstests/mrfs_*.exe fails)
    • fstests/fsrofs01.exe
    • libtests/flashdisk01.exe
  • libdevnull
    • sptests/sp21.exe
    • psxtests/psxmmap01.exe
    • tmtests/tm20.exe
  • libblock
    • fstests/fsbdpart01.exe

Command used for configuring leon3:

../rtems/configure \
--prefix=$HOME/development/rtems/5 \
--target=sparc-rtems5 \
--enable-rtemsbsp=leon3 \
--enable-posix --enable-tests

command used for running covoar:

covoar -vvvv -S /home/lunatic/development/rtems/rtems-tools/tester/rtems/testing/coverage/leon3-qemu-symbols.ini  \
-O leon3-qemu-coverage \
-E /home/lunatic/development/rtems/rtems-tools/tester/rtems/testing/coverage/Explanations.txt \
-p RTEMS-5 `find . -name *.exe`

Change History (3)

comment:1 Changed on Sep 13, 2018 at 11:24:18 PM by Chris Johns

Component: admintool

comment:2 Changed on Mar 12, 2019 at 6:24:40 PM by Joel Sherrill

Is this still an issue or did it get fixed?

comment:3 in reply to:  2 Changed on Mar 12, 2019 at 7:41:30 PM by Vijay Kumar Banerjee

Replying to Joel Sherrill:

Is this still an issue or did it get fixed?

I just tried running (leon3 with sis and qemu) and it seems like it's still an issue.

Note: See TracTickets for help on using tickets.