#3511 closed defect (duplicate)

int/pointer size warnings in powerpc-qoriq_e6500_64

Reported by: Joel Sherrill Owned by: Sebastian Huber
Priority: normal Milestone: 5.1
Component: arch/powerpc Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

These all look suspiciously like real issues:

$ grep warning log/powerpc-qoriq_e6500_64.log
../../../../../../../../rtems/c/src/lib/libbsp/powerpc/qoriq/../../../../../../bsps/powerpc/qoriq/start/bspstart.c:173:5: warning: passing argument 1 of 'qoriq_initialize_exceptions' makes pointer from integer without a cast [-Wint-conversion]
../../../../../../rtems/c/src/../../cpukit/libmisc/rtems-fdt/rtems-fdt-shell.c:57:27: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
../../../../../../rtems/c/src/../../cpukit/libmisc/rtems-fdt/rtems-fdt-shell.c:64:27: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
../../../../../../rtems/c/src/../../cpukit/libmisc/rtems-fdt/rtems-fdt-shell.c:488:11: warning: format '%u' expects argument of type 'unsigned int', but argument 5 has type 'long int' [-Wformat=]
../../../../../../rtems/c/src/../../cpukit/libmisc/rtems-fdt/rtems-fdt-shell.c:536:13: warning: format '%u' expects argument of type 'unsigned int', but argument 2 has type 'long int' [-Wformat=]
../../../../../../../../rtems/c/src/lib/libbsp/powerpc/qoriq/../../../../../../bsps/powerpc/shared/exceptions/ppc_exc_alignment.c:28:25: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
../../../../../../../../rtems/c/src/lib/libbsp/powerpc/qoriq/../../../../../../bsps/powerpc/shared/exceptions/ppc_exc_initialize.c:38:10: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]

Change History (2)

comment:1 Changed on Sep 4, 2018 at 10:57:32 PM by Joel Sherrill

Owner: set to Sebastian Huber
Status: newassigned

comment:2 Changed on Sep 5, 2018 at 4:56:38 AM by Sebastian Huber

Resolution: duplicate
Status: assignedclosed

Duplicate of #3156.

Note: See TracTickets for help on using tickets.