#3474 closed defect (worksforme)

error: no build set file found: 4.11/rtems-arm.bset

Reported by: FredDeCaro Owned by:
Priority: high Milestone: 4.11.4
Component: tool/rsb Version: 4.11
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

I was trying to follow the instruction here:
https://docs.rtems.org/releases/rtems-docs-4.11.2/user/installation/index.html#installation

I was trying to build a tool chain for the ARM architecture as descibed. Below is my output and error:

$ pwd
/c/opt/rtems/4_11_2

$ ./source-builder/sb-set-builder --prefix=/opt/rtems/4.11 --jobs=none 4.11/rtems-arm
RTEMS Source Builder - Set Builder, 4.11.not_released
Build Set: 4.11/rtems-arm
error: no build set file found: 4.11/rtems-arm.bset
Build Set: Time 0:00:00
Build FAILED

$ uname -a
CYGWIN_NT-6.1-WOW64 AZ25CY5LJH2W 1.7.16(0.262/5/3) 2012-07-20 22:55 i686 Cygwin

Change History (3)

comment:1 Changed on Jul 23, 2018 at 10:47:15 PM by Joel Sherrill

Component: admintool/rsb

I think you missed the "cd rtems" before you tried to build the tools. If this fixes your problem, please close. If this is incorrect in documentation, please let us know so we can fix that. Thansk.

cd rtems
../source-builder/sb-set-builder --log=l-arm.txt --prefix=/home/joel/rtems-411-work/tools/4.11 4.11/rtems-arm

comment:2 Changed on Jul 23, 2018 at 11:31:37 PM by FredDeCaro

That worked. Thanks. Please close ticket.

comment:3 Changed on Jul 24, 2018 at 12:02:46 AM by Joel Sherrill

Resolution: worksforme
Status: newclosed

Glad it was something simple. Good luck with RTEMS!

Note: See TracTickets for help on using tickets.