#3423 closed defect (duplicate)

examples-v2: m68k/powerpc BSPs undefined reference to _Thread_Life_action_handler

Reported by: Joel Sherrill Owned by:
Priority: normal Milestone: 5.1
Component: admin Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description (last modified by Chris Johns)

fat_ramdisk is failing to link on multiple m68k and powerpc BSPs. Errors below the list of BSPs

m68k-av5282
m68k-gen68340
m68k-gen68360
m68k-gen68360_040
m68k-mcf5206elite
m68k-mcf52235
m68k-mcf5225x
m68k-mcf5235
m68k-mcf5329
m68k-mrm332
m68k-pgh360
m68k-uC5282
powerpc-mpc8260ads
powerpc-qemuppc
powerpc-qoriq_e6500_64
powerpc-ss555

[20/20] Processing rtrace: build/m68k-rtems5-av5282/filesystem/fat_ramdisk/init.c.4.o build/m68k-rtems5-av5282/filesystem/fat_ramdisk/fs-root-tar.c.4.o -> build/m68k-rtems5-av5282/filesystem/fat_ramdisk/fat_ramdisk.texe
/home/joel/rtems-work/tools/5/bin/m68k-rtems5-gcc: /tmp/ccIRjaaa.o: In function `__wrap__Thread_Life_action_handler':
/home/joel/rtems-work/tools/5/bin/m68k-rtems5-gcc: /tmp/cckrhaaa.c:1248: undefined reference to `_Thread_Life_action_handler'
/home/joel/rtems-work/tools/5/bin/m68k-rtems5-gcc: collect2: error: ld returned 1 exit status
error: linking: Linker error

Change History (3)

comment:1 Changed on May 2, 2018 at 12:24:47 AM by Chris Johns

Description: modified (diff)

comment:2 Changed on May 2, 2018 at 12:29:00 AM by Chris Johns

Resolution: duplicate
Status: newclosed

This is the a duplicate of #3413 so I am closing it. The solution is in that ticket.

comment:3 Changed on May 2, 2018 at 12:30:39 AM by Joel Sherrill

#3413 should be updated with the list of BSPs which fail.

Note: See TracTickets for help on using tickets.