#3403 closed defect (fixed)

RSB RTEMS tool set build is irreproducible

Reported by: Sebastian Huber Owned by: Sebastian Huber
Priority: normal Milestone: 5.1
Component: tool/rsb Version: 5
Severity: major Keywords:
Cc: Blocked By:
Blocking:

Description

The RTEMS 5 tool set contains the RTEMS tools (rtems-tools). The version of the RTEMS tools is determined by the tool set build time since the current Git master branch is fetched. Instead use an explicit RTEMS tools version (similar to all other tools, e.g. Binutils, Newlib, GCC, GDB) to make the RTEMS tool set independent of the arbitrary build time.

Change History (1)

comment:1 Changed on Apr 18, 2018 at 8:07:30 AM by Sebastian Huber <sebastian.huber@…>

Resolution: fixed
Status: assignedclosed

In 50593d4/rtems-source-builder:

5: Use a specific RTEMS tools version

Download via cgit archive.

Close #3403.

Note: See TracTickets for help on using tickets.