#3255 closed defect (duplicate)

Warnings on 64-bit targets

Reported by: Joel Sherrill Owned by: Sebastian Huber
Priority: normal Milestone: 5.1
Component: arch/powerpc Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

This occurred on the 64 bit PowerPC and SPARC64 targets.

log/powerpc-qoriq_e6500_64.log:../../../../../../rtems/c/src/../../cpukit/libmisc/rtems-fdt/rtems-fdt-shell.c:57:27: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
log/powerpc-qoriq_e6500_64.log:../../../../../../rtems/c/src/../../cpukit/libmisc/rtems-fdt/rtems-fdt-shell.c:64:27: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
log/powerpc-qoriq_e6500_64.log:../../../../../../rtems/c/src/../../cpukit/libmisc/rtems-fdt/rtems-fdt-shell.c:488:11: warning: format '%u' expects argument of type 'unsigned int', but argument 5 has type 'long int' [-Wformat=]
log/powerpc-qoriq_e6500_64.log:../../../../../../rtems/c/src/../../cpukit/libmisc/rtems-fdt/rtems-fdt-shell.c:536:13: warning: format '%u' expects argument of type 'unsigned int', but argument 2 has type 'long int' [-Wformat=]

Change History (2)

comment:1 Changed on Nov 29, 2017 at 7:02:35 PM by Joel Sherrill

Owner: set to Sebastian Huber
Status: newassigned

comment:2 Changed on Nov 30, 2017 at 6:12:12 AM by Sebastian Huber

Resolution: duplicate
Status: assignedclosed

This is a duplicate of #3156.

Note: See TracTickets for help on using tickets.