#3018 closed task (fixed)

RSB cannot compile tool chain in CentOS 7.

Reported by: phongvanpham Owned by: Chris Johns
Priority: normal Milestone: 5.1
Component: tool/rsb Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

In CentOS 6.8, everything works fine. But in CentOS 7, it does not. Initial investigation (I did a while back around New Year time) looks like later version of texinfo has an issue with autoconf. Enclosed is the email Chris Johns replied but I didn't follow through since I switched to CentOS 6.8 for my work.

"Looks to me like the RSB is trying to download autoconf 2.69-1 and from
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=711297

Looks like this autoconf version has a bug. I also noticed my autoconf version is 2.69-11; however, from what I am reading, RSB will download its own version independent of what user has."

Chris John replies:

"I guess a recent texinfo version has exposed the issue. I suggest you get the patch from the link in the bug report, create a patch for rtems-tools.git to add the autoconf patch, then create a patch to the RSB adding the patch to the autoconf build, finally 'git send-email' the patches to devel@… for review."

Attachments (1)

rsb-report-autoconf-2.69-x86_64-linux-gnu-1.txt (19.9 KB) - added by phongvanpham on May 10, 2017 at 12:40:43 AM.

Download all attachments as: .zip

Change History (5)

comment:1 Changed on May 11, 2017 at 7:31:02 AM by Sebastian Huber

Milestone: 4.124.12.0

comment:2 Changed on Aug 23, 2017 at 10:55:10 PM by Chris Johns

Joel, is this still valid?

comment:3 Changed on Aug 24, 2017 at 8:18:25 AM by Sebastian Huber

Resolution: fixed
Status: newclosed

I built all tools today on a CentOS 7 machine without errors.

comment:4 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.