#3008 closed defect (fixed)

missing pax causes install failures

Reported by: Hassan Karim Owned by: chrisj@…
Priority: normal Milestone: 5.1
Component: doc Version: 5
Severity: normal Keywords: pax; testsuites
Cc: Blocked By:
Blocking:

Description

I have tried to install sparc bsp=erc32 on 4 different builds. 3 failed, and 1 flawlessly installed. The others all seem to fail somewhere during make install of test suites. Each reports one missing config problem or another.

I believe the problem resulted in a missing package, pax & libbsd-dev on Ubuntu 12.04.5 LTS (GNU/Linux 3.2.0-126-virtual x86_64)

I hadn't seen this exact problem because I normally update & upgrade as soon as I get a new image. Pressed for time, I skipped it. So, I am not sure if we need to update the documentation to directly include pax, since it is directly called in configure and breaks if not present.

https://docs.rtems.org/rsb/#_host_setups
Under this section,
11.1.5. Ubuntu

Add pax to this line
$ sudo apt-get build-dep binutils gcc g++ gdb unzip git python2.7-dev pax

Change History (6)

comment:1 Changed on May 7, 2017 at 10:54:11 PM by Chris Johns

This looks like a duplicate of #2437.

Solving this issue cleanly at the RSB level requires teaching the RSB about packages and then providing per host integration to the local packaging system if one is present. The RSB can build anything and so it is difficult to create a per host install list for everything that it could build. As a result there is currently a middle ground that is not cleanly covered leaving holes such as this one.

For pax please provide a documentation patch.

comment:2 Changed on May 7, 2017 at 10:58:24 PM by Chris Johns

Also the latest RSB documentation is https://docs.rtems.org/branches/master/rsb/index.html

comment:3 Changed on May 11, 2017 at 7:31:02 AM by Sebastian Huber

Milestone: 4.124.12.0

comment:4 Changed on Sep 4, 2017 at 3:33:35 AM by Chris Johns <chrisj@…>

Resolution: fixed
Status: newclosed

In 2cc9e2a/rtems-docs:

Add PAX to the Ubuntu packages to install.

Closes #3008.

comment:5 Changed on Oct 10, 2017 at 6:06:29 AM by Sebastian Huber

Component: Documentationdoc

comment:6 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.