#2996 closed defect (fixed)

source download for RTEMS 4.11.2-rc1 Release

Reported by: tnagy Owned by: Chris Johns
Priority: normal Milestone: 4.11.2
Component: unspecified Version: 4.11
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

A while back

Following the instructions on https://ftp.rtems.org/pub/rtems/releases/4.11/rc/4.11.2-rc1/ and running: ../source-builder/sb-set-builder --prefix=$HOME/development/rtems/4.11.2-rc1 4.11/rtems-sparc

making dir: /home/user/development/rtems/rtems-source-builder-4.11.2-rc1/rtems/sources
download: ftp://ftp.rtems.org/pub/rtems/releases/4.11/4.11.2-rc1/rtems-tools-4.11.2-rc1.tar.xz -> sources/rtems-tools-4.11.2-rc1.tar.xz
download: ftp://ftp.rtems.org/pub/rtems/releases/4.11/4.11.2-rc1/rtems-tools-4.11.2-rc1.tar.xz -> sources/rtems-tools-4.11.2-rc1.tar.xz
download: ftp://ftp.rtems.org/pub/rtems/releases/4.11/4.11.2-rc1/rtems-tools-4.11.2-rc1.tar.xz: error: <urlopen error ftp error: 550 Failed to change directory.>
error: downloading ftp://ftp.rtems.org/pub/rtems/releases/4.11/4.11.2-rc1/rtems-tools-4.11.2-rc1.tar.xz: all paths have failed, giving up

The path does not exist. I tried to change the path in source-builder/defaults.mc:
rtems_release_url: none, none, 'https://ftp.rtems.org/pub/rtems/releases/%{rtems_version}'

As it seems *very* strange that ftp is used by default when https should work. In the end, i downloaded the files such as rtems-source-builder-4.11.2-rc1.tar.xz and placed them in the folder sources/ and then the build worked.

Change History (4)

comment:1 in reply to:  description Changed on Apr 17, 2017 at 10:53:32 PM by Chris Johns

Owner: set to Chris Johns
Status: newassigned

Replying to tnagy:

A while back

Following the instructions on https://ftp.rtems.org/pub/rtems/releases/4.11/rc/4.11.2-rc1/ and running: ../source-builder/sb-set-builder --prefix=$HOME/development/rtems/4.11.2-rc1 4.11/rtems-sparc

making dir: /home/user/development/rtems/rtems-source-builder-4.11.2-rc1/rtems/sources
download: ftp://ftp.rtems.org/pub/rtems/releases/4.11/4.11.2-rc1/rtems-tools-4.11.2-rc1.tar.xz -> sources/rtems-tools-4.11.2-rc1.tar.xz
download: ftp://ftp.rtems.org/pub/rtems/releases/4.11/4.11.2-rc1/rtems-tools-4.11.2-rc1.tar.xz -> sources/rtems-tools-4.11.2-rc1.tar.xz
download: ftp://ftp.rtems.org/pub/rtems/releases/4.11/4.11.2-rc1/rtems-tools-4.11.2-rc1.tar.xz: error: <urlopen error ftp error: 550 Failed to change directory.>
error: downloading ftp://ftp.rtems.org/pub/rtems/releases/4.11/4.11.2-rc1/rtems-tools-4.11.2-rc1.tar.xz: all paths have failed, giving up

The path does not exist. I tried to change the path in source-builder/defaults.mc:
rtems_release_url: none, none, 'https://ftp.rtems.org/pub/rtems/releases/%{rtems_version}'

This has been fixed with 4.11.2-rc4. Please refer to #2952 for details.

As it seems *very* strange that ftp is used by default when https should work. In the end, i downloaded the files such as rtems-source-builder-4.11.2-rc1.tar.xz and placed them in the folder sources/ and then the build worked.

The ftp default is set here in the RSB defaults and I have not changed it. It dates back to just having ftp access. Yes it should be changed.

comment:2 Changed on Apr 17, 2017 at 11:01:39 PM by Joel Sherrill

The issue is not the protocol, it is the path. There was/is a mistake in the RSB in generating the URL.

FWIW RTEMS has had parallel ftp/http access much much longer than the RSB has existed.

comment:3 in reply to:  2 Changed on Apr 18, 2017 at 1:10:30 AM by Chris Johns

Replying to Joel Sherrill:

The issue is not the protocol, it is the path. There was/is a mistake in the RSB in generating the URL.

The issue is discussed in the other ticket. It had 2 parts, first the release script did not create the correct release URL in the VERSION's file a release contains and secondly the tools and kernel contained a hard coded path to the expected release directory and did not honor the VERSION's release URL. Both issues combined to break the RC's 1 to 3 when hosted in the rc subdir. I moved 4.11.2-rc1 from the 4.11 directory to the rc directory once I had a working RC available to clean up knowing it would break.

The latest rc4 has the fixes.

FWIW RTEMS has had parallel ftp/http access much much longer than the RSB has existed.

I seem to remember the path was not the same and one had extra levels. I think the default should be changed to https.

comment:4 Changed on Jul 11, 2017 at 12:36:26 AM by Chris Johns

Resolution: fixed
Status: assignedclosed

Fixed.

Note: See TracTickets for help on using tickets.