#2995 closed defect (fixed)

Missing bsets

Reported by: Hassan Karim Owned by: joel.sherrill@…
Priority: normal Milestone: 5.1
Component: tool/rsb Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

When I went to rebuild based on 4.12, I cloned from github.
I am no longer getting all of the b-sets that I was expecting. Specifically, 4.12/rtems-sparc

Chris Johns said to submit it as a bug. It must have happened within the last couple of weeks. As my scripts that automated these tasks were working as of around 3/1/2017

git clone git://git.rtems.org/rtems-source-builder.git
$SETBLDRSCRIPTDIR/sb-set-builder --list-bsets

RTEMS Source Builder - Set Builder, 4.12 (2074bd1168ee)
Examining: config
Examining: ../rtems/src/rtems-source-builder/source-builder/config
Examining: ../rtems/src/rtems-source-builder/bare/config
devel/autotools-base.bset
devel/autotools-internal.bset
devel/autotools.bset
devel/dtc.bset
devel/libtool.bset
devel/libusb.bset
devel/or1ksim.bset
devel/qemu.bset
gnu-tools-4.6.bset
gnu-tools-4.8.2.bset
lang/gcc491.bset

Change History (9)

comment:1 Changed on Apr 17, 2017 at 3:29:20 AM by Joel Sherrill

When you mentioned GitHub?, I wondered if the mirroring was broken. It is not. And it looks like rtems/config/4.12 has the right content.

I will try the script in the morning to see what it lists on my computer.

comment:2 Changed on Apr 17, 2017 at 3:44:58 AM by Hassan Karim

What could I look for specifically by hand in the git repository?

comment:3 Changed on Apr 17, 2017 at 2:32:04 PM by Joel Sherrill

I don't think you need to look at anything. I can confirm the script doesn't find the RTEMS 4.12 bsets. It isn't seeing anything in the rtems/ directory.

$ ./source-builder/sb-set-builder --list-bsets
RTEMS Source Builder - Set Builder, 4.12 (2074bd1168ee)
Examining: config
Examining: source-builder/config
Examining: bare/config

devel/autotools-base.bset
devel/autotools-internal.bset
devel/autotools.bset
devel/dtc.bset
devel/libtool.bset
devel/libusb.bset
devel/or1ksim.bset
devel/qemu.bset
gnu-tools-4.6.bset
gnu-tools-4.8.2.bset
lang/gcc491.bset

The rtems 4.12 bset's are:

$ ls rtems/config/4.12
rtems-aarch64.bset rtems-i386.bset rtems-powerpc.bset
rtems-all.bset rtems-lm32.bset rtems-sh.bset
rtems-arm.bset rtems-m32c.bset rtems-sparc64.bset
rtems-autotools-base.bset rtems-m68k.bset rtems-sparc.bset
rtems-autotools.bset rtems-microblaze.bset rtems-tools.bset
rtems-autotools-internal.bset rtems-mips.bset rtems-v850.bset
rtems-bfin.bset rtems-moxie.bset rtems-x86_64.bset
rtems-default.bset rtems-nios2.bset
rtems-epiphany.bset rtems-or1k.bset

cd into rtems/ and then run set-builder using any of those. This is just a problem with the --list-bsets.

comment:4 Changed on Apr 29, 2017 at 11:57:37 AM by Hassan Karim

Thanks. It worked.

comment:5 Changed on Apr 29, 2017 at 5:24:34 PM by Joel Sherrill

Good news. Please close if it is resolved n

comment:6 Changed on May 11, 2017 at 7:31:02 AM by Sebastian Huber

Milestone: 4.124.12.0

comment:7 Changed on Oct 10, 2017 at 6:57:05 AM by Sebastian Huber

Component: bspstool/rsb

comment:8 Changed on Oct 12, 2017 at 1:07:54 AM by Joel Sherrill

Resolution: fixed
Status: newclosed

comment:9 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.