#2989 closed infra (fixed)

doxygen crashes on sync.rtems.org

Reported by: Chris Johns Owned by: Amar Takhar
Priority: highest Milestone: 4.11.2
Component: admin Version: 4.11
Severity: blocker Keywords:
Cc: Blocked By:
Blocking:

Description

Attempting to create a release on sync.rtems.org results in a core being dumped:

Running dot for graph 3822/7363
Running dot for graph 3823/7363
Segmentation fault (core dumped)

Run doxygen on a recent RTEMS kernel. This does not happen another 11.0 machine I have. That version of doxygen is 1.8.12 and sync.rtems.org as 1.8.13.

I have seen other erratic behaviour such as git not working, disks not

Change History (6)

comment:1 Changed on Apr 11, 2017 at 10:39:57 PM by Chris Johns

The place the crash happens moves.

The git issue is an issue related to changes I have made.

comment:2 Changed on Apr 11, 2017 at 11:42:05 PM by Amar Takhar

Owner: changed from amar@… to Amar Takhar
Status: newaccepted

This is usually caused by Doxygen running too many parallel dot processes. You can fix it by adding

DOT_NUM_THREADS = 5

to your Doxyfile. You may be able to increase from 5 this is just the default that I use.

If that doesn't fix it let me know.

comment:3 in reply to:  2 Changed on Apr 12, 2017 at 2:31:58 AM by Chris Johns

Replying to Amar Takhar:

If that doesn't fix it let me know.

Setting the thread count to 5 does not work. Testing 1 now.

comment:4 Changed on Apr 12, 2017 at 2:39:10 AM by Chris Johns

I should add I have never seen a crash on my 11.0 box doing the same thing.

comment:5 Changed on Apr 12, 2017 at 9:09:02 PM by Chris Johns

Resolution: fixed
Status: acceptedclosed

Using single threaded mode ({{DOT_NUM_THREADS = 1}}) works. It is painfully slow but I can live with that.

comment:6 in reply to:  5 Changed on Apr 12, 2017 at 9:13:36 PM by Chris Johns

Replying to Chris Johns:

Using single threaded mode (DOT_NUM_THREADS = 1) works. It is painfully slow but I can live with that.

Note: See TracTickets for help on using tickets.