#2952 closed enhancement (fixed)

Support a release candidates residing in an `rc` directory.

Reported by: Chris Johns Owned by: Chris Johns
Priority: high Milestone: 4.11.2
Component: tool/rsb Version: 4.11
Severity: trivial Keywords:
Cc: Blocked By:
Blocking:

Description

Update the RSB to look for release candidate packages in an rc directory. This removes these packages from the main release directory and stops them cluttering the main release directory keeping the focus on the releases.

Change History (8)

comment:1 Changed on Mar 26, 2017 at 2:21:17 AM by Chris Johns <chrisj@…>

Resolution: fixed
Status: assignedclosed

In dca7ab2/rtems-source-builder:

sb: Add the release_path key to the version section in the VERSION file.

A release can specify a custom releaase URL path.

Closes #2952.

comment:2 Changed on Apr 10, 2017 at 6:38:04 AM by Chris Johns

Resolution: fixed
Status: closedreopened

The bug still exists.

The issue is due to the tools and kernel configuration scripts having %define without_release_url because the source for the tools and kernel is not located in the sources directory in the release. Splitting the sources into separate paths only complicates things so it is best to remove the path hack and have the tools and kernel source in the sources directory of a release as well as the release's top level directory.

comment:3 Changed on Apr 10, 2017 at 7:34:31 AM by Chris Johns <chrisj@…>

In 44ebcc5/rtems-source-builder:

Fix the tools and kernel source URL when released to use sources.

Remove %define without_release_url so the standard release URL processing
is used. This requires the tools and kernel source is available in the
releases sources directory.

Updates #2952.

comment:4 Changed on Apr 10, 2017 at 7:34:50 AM by Chris Johns <chrisj@…>

In 61e2617/rtems-source-builder:

Fix the tools and kernel source URL when released to use sources.

Remove %define without_release_url so the standard release URL processing
is used. This requires the tools and kernel source is available in the
releases sources directory.

Updates #2952.

comment:5 Changed on Apr 11, 2017 at 8:56:24 PM by Chris Johns <chrisj@…>

In 949731c/rtems-source-builder:

Fix rtems-tools and rtems-kernel builds when released and with a release URL.

Updates #2952.

comment:6 Changed on Apr 12, 2017 at 10:43:53 PM by Chris Johns <chrisj@…>

In 576e284/rtems-source-builder:

Fix the release builds of rtems-tools and kernel.

Updates #2952.

comment:7 Changed on Apr 13, 2017 at 1:02:07 AM by Chris Johns <chrisj@…>

In 4141cca/rtems-source-builder:

Fix rtems-tools and rtems-kernel builds when released and with a release URL.

Updates #2952.

comment:8 Changed on Apr 13, 2017 at 1:03:56 AM by Chris Johns

Resolution: fixed
Status: reopenedclosed

Fix on the 4.11 and master branches.

Note: See TracTickets for help on using tickets.