#2883 closed defect (fixed)

src/c/src/lib/libbsp/arm/tms570/console/tms570-sci.c:248: strange expression ?

Reported by: David Binderman Owned by: Pavel Pisa
Priority: normal Milestone: 5.1
Component: arch/arm Version: 4.11
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

src/c/src/lib/libbsp/arm/tms570/console/tms570-sci.c:248]: (style) Same expression on both sides of '|'.

Source code is

uint32_t flr_tx_ready = TMS570_SCI_FLR_TX_EMPTY | TMS570_SCI_FLR_TX_EMPTY;

Change History (6)

comment:1 Changed on Jan 24, 2017 at 6:41:28 AM by Sebastian Huber

Owner: set to Pavel Pisa
Status: newassigned

comment:2 Changed on May 11, 2017 at 7:31:02 AM by Sebastian Huber

Milestone: 4.124.12.0

comment:3 Changed on Oct 12, 2017 at 5:38:41 PM by Joel Sherrill

Ping Paval. Any idea what this line of code should be?

comment:4 Changed on Oct 12, 2017 at 11:03:14 PM by Pavel Pisa <ppisa@…>

Resolution: fixed
Status: assignedclosed

In f4009d8/rtems:

bsp/tms570: remove duplicate of TMS570_SCI_FLR_TX_EMPTY in console driver.

Initial idea has been that check for both, TMS570_SCI_FLR_TX_EMPTY
and TMS570_SCI_FLR_TXRDY is required before console driver parameters
update.

closes #2883.

comment:5 Changed on Oct 16, 2017 at 6:24:30 AM by Sebastian Huber

Component: unspecifiedarch/arm

comment:6 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.