#2835 closed defect (duplicate)

Ada support is broken on SMP configurations

Reported by: Sebastian Huber Owned by: Needs Funding
Priority: normal Milestone: 5.1
Component: tool/gcc Version: 4.11
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

The Ada support is the last user of a task variable: rtems_ada_self. This doesn't work on SMP configurations. The Ada support in GCC should be changed to use a function call or C11 thread-local storage.

Change History (4)

comment:1 Changed on Mar 7, 2017 at 10:07:33 AM by Sebastian Huber

Milestone: 5.0Indefinite
Owner: set to Needs Funding
Status: newassigned

comment:2 Changed on May 23, 2017 at 7:58:43 AM by Sebastian Huber

Resolution: duplicate
Status: assignedclosed

This is a duplicate of #2289.

comment:3 Changed on Oct 5, 2017 at 8:31:08 AM by Sebastian Huber

Milestone: Indefinite4.12.0

comment:4 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.