#2664 closed defect (duplicate)

spclock_err02

Reported by: Joel Sherrill Owned by: Sebastian Huber
Priority: normal Milestone: 5.1
Component: score Version: 5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

New test failure on sis but likely all targets.

* BEGIN OF TEST SPCLOCK_ERR 2 *
TA1 - rtems_io_close - RTEMS_INVALID_NUMBER
TA1 - rtems_io_control - RTEMS_INVALID_NUMBER
TA1 - rtems_io_initialize - RTEMS_INVALID_NUMBER
TA1 - rtems_io_open - RTEMS_INVALID_NUMBER
TA1 - rtems_io_read - RTEMS_INVALID_NUMBER
TA1 - rtems_io_write - RTEMS_INVALID_NUMBER
TA1 - rtems_clock_set - 23:59:59 12/31/2000 - RTEMS_SUCCESSFUL
TA1 - rtems_clock_get_tod - 00:00:00 01/01/2001 - RTEMS_SUCCESSFUL
TA1 - rtems_clock_set - 23:59:59 12/31/1999 - RTEMS_SUCCESSFUL
TA1 - rtems_clock_get_tod - 00:00:00 01/01/2000 - RTEMS_SUCCESSFUL
assertion "ticks < 0x400000000" failed: file "../../cpukit/../../../sis/lib/include/rtems/score/watchdogimpl.h", line 316, function: _Watchdog_Ticks_from_timespec

Breakpoint 1, _Terminate (the_source=the_source@entry=RTEMS_FATAL_SOURCE_ASSERT,

is_internal=is_internal@entry=false, the_error=the_error@entry=33694096)
at ../../../../../../rtems/c/src/../../cpukit/score/src/interr.c:36

36 {
(gdb) bt
#0 _Terminate (the_source=the_source@entry=RTEMS_FATAL_SOURCE_ASSERT,

is_internal=is_internal@entry=false, the_error=the_error@entry=33694096)
at ../../../../../../rtems/c/src/../../cpukit/score/src/interr.c:36

#1 0x0200aed4 in rtems_fatal (source=source@entry=RTEMS_FATAL_SOURCE_ASSERT,

error=error@entry=33694096)
at ../../../../../../rtems/c/src/../../cpukit/sapi/src/fatal2.c:34

#2 0x02004a9c in assert_func (

file=file@entry=0x201a650 "../../cpukit/../../../sis/lib/include/rtems/score/watchdogimpl.h", line=line@entry=316,
func=func@entry=0x201a6d0 <func.3277> "_Watchdog_Ticks_from_timespec",
failedexpr=failedexpr@entry=0x201a638 "ticks < 0x400000000")
at ../../../../../../rtems/c/src/../../cpukit/libcsupport/src/assert.c:52

#3 0x0200bbf8 in _Watchdog_Ticks_from_timespec (ts=0x2022210)

at ../../cpukit/../../../sis/lib/include/rtems/score/watchdogimpl.h:316

#4 _TOD_Set_with_timestamp (tod_as_timestamp=tod_as_timestamp@entry=0x2022280)

at ../../../../../../rtems/c/src/../../cpukit/score/src/coretodset.c:40

#5 0x02009880 in rtems_clock_set (tod=tod@entry=0x2022304)

at ../../../../../../rtems/c/src/../../cpukit/rtems/src/clockset.c:42

#6 0x02001818 in Init (argument=<optimized out>)

at ../../../../../../../rtems/c/src/../../testsuites/sptests/spclock_err02/init.c:93

#7 0x0200fcbc in _Thread_Entry_adaptor_numeric (executing=0x201fb90)

at ../../../../../../rtems/c/src/../../cpukit/score/src/threadentryadaptornumeric---Type <return> to continue, or q <return> to quit---

.c:25
#8 0x02012e0c in _Thread_Handler ()

at ../../../../../../rtems/c/src/../../cpukit/score/src/threadhandler.c:93

#9 0x02012d60 in _Thread_Handler ()

at ../../../../../../rtems/c/src/../../cpukit/score/src/threadhandler.c:29

(gdb) l init.c:93
88 status = rtems_clock_get_tod( &time );
89 directive_failed( status, "rtems_clock_get_tod" );
90 print_time( "TA1 - rtems_clock_get_tod - ", &time, " - RTEMS_SUCCESSFUL\n" );
91
92 build_time( &time, 12, 31, 2100, 23, 59, 59, 0 );
93 status = rtems_clock_set( &time );
94 directive_failed( status, "rtems_clock_set" );
95 print_time( "TA1 - rtems_clock_set - ", &time, " - RTEMS_SUCCESSFUL\n" );
96 status = rtems_task_wake_after( rtems_clock_get_ticks_per_second() );
97 status = rtems_clock_get_tod( &time );
(gdb)

Change History (3)

comment:1 Changed on Mar 21, 2016 at 6:37:48 AM by Sebastian Huber

Resolution: duplicate
Status: newclosed

This is with RTEMS_DEBUG enabled and is a duplicate of #2624. See also comment in _Watchdog_Ticks_from_timespec().

comment:2 Changed on May 11, 2017 at 7:31:02 AM by Sebastian Huber

Milestone: 4.124.12.0

comment:3 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.