#2605 closed defect (fixed)

RSB does not handle waf --destdir connectly with MSYS2

Reported by: Chris Johns Owned by: Chris Johns
Priority: high Milestone: 4.11
Component: tool/rsb Version: 4.11
Severity: critical Keywords:
Cc: Blocked By:
Blocking:

Description


Change History (3)

comment:1 Changed on Feb 22, 2016 at 6:05:58 AM by Chris Johns

The RTEMS tools do not get installed correctly.

A configure script appends the POSIX version of the --prefix path to DESTDIR when using 'make DESTDIR=/C/destdir install'. This means if a prefix is '/C/prefix' is used with a DESTDIR of '/C/destdir' the resultant path is '/C/destdir/C/prefix. Note the double '/C/'.

With the same paths waf results in '/C/destdir/prefix' which is correct because there is no drive annotation you can use, both paths are on the same drive. The RSB does not handle this path so it copies an empty tree to the final install path

The issue is a weird mix of shell configures scripts at the POSIX level building native Windows programs and waf which is using Windows paths.

There is no clear solution and so the config file for the waf build needs to handle this special case.

Last edited on Feb 22, 2016 at 6:06:13 AM by Chris Johns (previous) (diff)

comment:2 Changed on Feb 22, 2016 at 6:46:23 AM by Chris Johns <chrisj@…>

Resolution: fixed
Status: newclosed

In 34dfc8380d1fa8456b12ae3094fc823875ac72d9/rtems-source-builder:

Fix the rtems-tools waf --destdir path on Windows.

Waf requires the drive be added to the destdir path so it installs to a path
the RSB knows. The RSB assumes the destdir contains an MSYS drive path as
seen in the POSIX path. This is default for configure scripts.

Also fix the git URL to pull before the branch command as well as after to
update the branch.

Closes #2605.

comment:3 Changed on Feb 22, 2016 at 6:46:52 AM by Chris Johns <chrisj@…>

In 318e0c3b0407c176632fa9deb7ec5383999d344e/rtems-source-builder:

Fix the rtems-tools waf --destdir path on Windows.

Waf requires the drive be added to the destdir path so it installs to a path
the RSB knows. The RSB assumes the destdir contains an MSYS drive path as
seen in the POSIX path. This is default for configure scripts.

Also fix the git URL to pull before the branch command as well as after to
update the branch.

Closes #2605.

Note: See TracTickets for help on using tickets.