#2538 closed defect (worksforme)

4.11 tools on RSB 4.11 branch fail to build

Reported by: Joel Sherrill Owned by: Chris Johns
Priority: high Milestone: 4.11.3
Component: tool/rsb Version: 4.11
Severity: blocker Keywords:
Cc: Blocked By:
Blocking:

Description

From the log building arm-rtems4.11 target. It is in rtems-tools and the ln only has one argument. Looks like I can expect all targets to fail.

+ /bin/rm -rf rtems-tools-4.11
+ ln -s /data/home/joel/rtems-4.11-work/rtems-source-builder/rtems/sources/git/rtems-tools.git
+ cd rtems-tools-4.11
/data/home/joel/rtems-4.11-work/rtems-source-builder/rtems/build/rtems-tools-4.11-1/doit: line 85: cd: rtems-tools-4.11: No such file or directory
shell cmd failed: /bin/sh -ex /data/home/joel/rtems-4.11-work/rtems-source-builder/rtems/build/rtems-tools-4.11-1/doit
error: building rtems-tools-4.11-1

Change History (7)

comment:1 Changed on Jan 20, 2016 at 12:14:27 AM by Chris Johns

Status: newaccepted

comment:2 Changed on Jan 25, 2016 at 4:53:59 PM by Mario Gruber

Duplicate of #2495

comment:3 Changed on Feb 19, 2016 at 3:11:25 AM by Chris Johns

I suspect the issue is the git command in the config file attempts to change to the 4.11 branch before a pull and if you have a repo in your sources directory that was cloned before the 4.11 branch was added it fails. I have changed the pull to be before the branch.

comment:4 Changed on Jan 26, 2017 at 7:16:00 AM by Sebastian Huber

Milestone: 4.11.14.11.2

comment:5 Changed on Mar 21, 2017 at 3:12:16 AM by Chris Johns

I just built 4.11/rtems-arm with out error. I cannot reproduce this on FreeBSD.

Can you please provide some more information?

comment:6 Changed on Mar 23, 2017 at 1:03:28 AM by Chris Johns

Milestone: 4.11.24.11.3

The 4.11.2 milestone is closing.

comment:7 Changed on Feb 7, 2018 at 5:15:39 AM by Chris Johns

Resolution: worksforme
Status: acceptedclosed

I cannot repeat this and the related code looks OK so without further details I cannot do much with this but report.

Note: See TracTickets for help on using tickets.