#2363 closed defect (duplicate)

SPARC: Silent FP context corruption possible

Reported by: Sebastian Huber Owned by:
Priority: lowest Milestone: 5.1
Component: arch/sparc Version: 4.11
Severity: critical Keywords:
Cc: Blocked By:
Blocking:

Description

On uni-processor configurations the post-switch actions (e.g. signal handlers) and context switch extensions may silently corrupt the floating point context. Set test sptests/spcontext01.

This problem exists for many years and might be working as intended. It is possible to fix this issue using the SPARC_USE_SAFE_FP_SUPPORT option. This is already used for the SMP configurations. The disadavantage is that this disables the deferred floating point support.

Change History (4)

comment:1 Changed on Jan 26, 2017 at 7:16:00 AM by Sebastian Huber

Milestone: 4.11.14.11.2

comment:2 Changed on Mar 23, 2017 at 1:04:45 AM by Chris Johns

Milestone: 4.11.24.11.3

The 4.11.2 milestone is closing.

comment:3 Changed on Feb 5, 2018 at 4:39:20 AM by Chris Johns

Milestone: 4.11.3Indefinite

Requires funding.

comment:4 Changed on Feb 5, 2018 at 7:49:50 AM by Sebastian Huber

Component: scorearch/sparc
Milestone: Indefinite5.1
Resolution: duplicate
Status: newclosed

Fixed by #3077.

Note: See TracTickets for help on using tickets.