Notice: We have migrated to GitLab launching 2024-05-01 see here: https://gitlab.rtems.org/

#2300 closed defect (fixed)

MIPS Tools fail to build.

Reported by: Chris Johns Owned by: Chris Johns
Priority: normal Milestone: Indefinite
Component: tool/rsb Version: 6
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

On FreeBSD 10.1 the MIPS tools fail to build. Attached is the RSB report.

Change History (12)

comment:1 Changed on 03/12/15 at 13:51:22 by Gedare Bloom

xgcc: error: addsf3: No such file or directory
xgcc: error: subsf3: No such file or directory
gmake[4]: * [subsf3.o] Error 1
../../../../gcc-4.9.2/libgcc/config/t-hardfp:71: recipe for target 'subsf3.o' failed

comment:2 Changed on 03/12/15 at 14:49:25 by Gedare Bloom

Milestone: 4.114.11.1

Tools build fine on Ubuntu 14.04. I am unable to reproduce your bug.

comment:3 Changed on 03/12/15 at 14:50:47 by Gedare Bloom

Check your gcc version. My host gcc uses 4.8.2

comment:4 Changed on 03/12/15 at 20:46:11 by Chris Johns

Milestone: 4.11.14.11

It fails on FreeBSD so that is a 4.11 issue. FreeBSD uses clang so that could be an issue.

Last edited on 03/12/15 at 20:46:51 by Chris Johns (previous) (diff)

comment:5 Changed on 08/30/15 at 10:46:49 by Anders Montonen

This is a bug in the build system of GCC 4.9+, the sed scripts in t-hardfp use nonstandard regexes that require GNU sed. See GCC bug 62097, https://gcc.gnu.org/bugzilla/show_bug.cgi?id=62097

comment:6 Changed on 09/02/15 at 14:11:59 by Joel Sherrill

I tracked the change down to the particular commit by Richard Sandiford and assigned it to him. I would expect him to be reasonably responsive.

comment:7 Changed on 01/26/17 at 07:05:37 by Sebastian Huber

Milestone: 4.114.11.2

comment:8 Changed on 02/15/17 at 13:37:51 by Sebastian Huber

Milestone: 4.11.2Indefinite
Owner: set to Needs Funding
Status: newassigned

comment:9 Changed on 09/14/22 at 06:22:21 by Chris Johns

Component: unspecifiedtool/rsb
Owner: changed from Needs Funding to Chris Johns
Version: 4.116

This is caused by the MIPS build of gcc requiring a GNU sed. It is the only architecture we support that has a need for GNU sed. It seems this will not change and I believe GCC says GNU sed is required.

Check the host sed command to see if it is GNU sed and if not build a local copy. No need to add it as a dependency package a host has to install.

comment:10 Changed on 09/14/22 at 20:52:57 by Chris Johns <chrisj@…>

In [changeset:"27c61da6df55787e4848c28ee2e0ea764a1246c2/rtems-source-builder" 27c61da/rtems-source-builder]:

textproc/gsed: Add GNU sed build support

Updates #2300

comment:11 Changed on 09/14/22 at 20:52:58 by Chris Johns <chrisj@…>

Resolution: fixed
Status: assignedclosed

In [changeset:"468fc79e8c7c8076e8b65be82ba2009e41dd6c8e/rtems-source-builder" 468fc79/rtems-source-builder]:

devel/gcc: Check and build GNU sed if not available on build host

Closes #2300

Note: See TracTickets for help on using tickets.