Notice: We have migrated to GitLab launching 2024-05-01 see here: https://gitlab.rtems.org/

#2277 closed defect (invalid)

RSB download from git.rtems.org fails with SSL cert error.

Reported by: Chris Johns Owned by:
Priority: normal Milestone: 4.11
Component: admin Version: 4.10
Severity: major Keywords: ssl
Cc: Blocked By:
Blocking:

Description

Using the RSB command of:

$ cd rtems-source-builder/rtems
$ ../source-builder/sb-set-builder --prefix=/opt/work/rtems/4.11 4.11/rtems-arm --dry-run --with-download

Returns ...
download: http://git.rtems.org/rtems-tools/plain/tools/4.11/gdb/gdb-sim-arange-inline.diff: error: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581)>

Change History (4)

comment:1 Changed on 03/02/15 at 20:44:42 by Gedare Bloom

Resolution: duplicate
Status: newclosed

dupe of #2195

comment:2 Changed on 03/02/15 at 20:46:17 by Amar Takhar

Resolution: duplicate
Status: closedreopened

Not a duplicate.

comment:3 Changed on 03/02/15 at 20:46:32 by Amar Takhar

Keywords: ssl added
Resolution: invalid
Status: reopenedclosed

This is a local error on your machine. Please check your certificate CA install.

comment:4 Changed on 03/05/15 at 00:01:07 by Amar Takhar

For anyone curious this is an issue on FreeBSD see here: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196357 The solution is in this ticket.

Note: See TracTickets for help on using tickets.