#2213 closed defect (fixed)

Decreased performance for whetstone benchmark using GCC >=4.5

Reported by: daniel.cederman Owned by: Daniel Hellstrom
Priority: normal Milestone: 5.1
Component: tool/gcc Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

Moving from GCC 4.4.2 to 4.9.2 increases the execution time of the whetstone benchmark on both SPARC and x86. The cause seems to be a single commit. I have submitted a bug report to the GCC bugzilla:

https://gcc.gnu.org/bugzilla/show_bug.cgi?id=64193

Change History (10)

comment:1 Changed on Jan 22, 2015 at 3:15:04 PM by Joel Sherrill

Daniel.. did this get resolved? I recall discussions.

comment:2 Changed on Jan 23, 2015 at 9:43:41 AM by daniel.cederman

Richard Biener provided a patch that fixed it on trunk. It looks like it could be easy to backport, but I have not had time to test it yet.

comment:3 Changed on Mar 2, 2015 at 8:48:06 PM by Gedare Bloom

Milestone: 4.114.11.1

comment:4 Changed on Jan 23, 2017 at 1:47:53 PM by Sebastian Huber

Owner: set to Needs Funding
Status: newassigned

How is the performance on GCC 6 or 7?

comment:5 Changed on Jan 23, 2017 at 1:48:08 PM by Sebastian Huber

Owner: changed from Needs Funding to Daniel Hellstrom

comment:6 Changed on Jan 23, 2017 at 2:53:23 PM by daniel.cederman

A quick test shows that the performance for GCC 7 is about the same as for GCC 4.4.6.

GCC 4.4.6 => ~52 seconds
GCC 4.9.4 => ~55 seconds
GCC 7.0.0 (master at 20170116) => ~52 seconds
Compiled with -O3 and -mcpu=leon3.

comment:7 Changed on Jan 23, 2017 at 2:55:31 PM by Sebastian Huber

Milestone: 4.11.14.12
Resolution: fixed
Status: assignedclosed

Fixed in RTEMS 4.12, no plans to fix this in RTEMS 4.11.

Last edited on Jan 23, 2017 at 2:55:44 PM by Sebastian Huber (previous) (diff)

comment:8 Changed on May 11, 2017 at 7:31:02 AM by Sebastian Huber

Milestone: 4.124.12.0

comment:9 Changed on Oct 10, 2017 at 5:58:26 AM by Sebastian Huber

Component: GCCtool/gcc

comment:10 Changed on Nov 9, 2017 at 6:27:14 AM by Sebastian Huber

Milestone: 4.12.05.1

Milestone renamed

Note: See TracTickets for help on using tickets.