#2115 closed enhancement (fixed)

Could we do a write check in the install directory before running?

Reported by: cynt6007 Owned by: Chris Johns
Priority: normal Milestone: 4.11
Component: tool/rsb Version: 4.11
Severity: minor Keywords:
Cc: Blocked By:
Blocking:

Description

During testing of feasibility of running RSB on gcc compile farm, ran ../source-builder/sb-set-builder unstable/4.11/rtems-avr.bset

The job started at ~11:30 PDT and ended at ~12:23 PDT. The job ended with the following error:

/home/cynt6007/rtems-source-builder/rtems/build/tmp/source-build-cynt6007/unstable/4.11/rtems-avr.bset/usr/lib/libiberty.a
installing: expat-2.1.0-x86_64-linux-gnu-1 -> /usr
Traceback (most recent call last):

File "../source-builder/sb-set-builder", line 26, in <module>

setbuilder.run()

File "../source-builder/sb/setbuilder.py", line 373, in run

b.build(deps)

File "../source-builder/sb/setbuilder.py", line 317, in build

b.config.expand('%{_prefix}'))

File "../source-builder/sb/setbuilder.py", line 136, in install

self.copy(src, dst)

File "../source-builder/sb/setbuilder.py", line 87, in copy

raise error.general('copying tree: %s: %s' % (what, str(err)))

NameError?: global name 'what' is not defined

From prior experience with this error on Debian, I know it's caused by RSB attempting to install in expat in the /usr directory.

Instead of giving an error and exiting after running an hour, could a write-check in the install directory be run BEFORE attempting to build the software? Could the error-message ask the user to change the prefix or use the root account?

The compile machine info:
gcc20 1TB 2x6x2.93 GHz Intel Dual Xeon X5670 2.93 GHz 12 cores 24 threads / 24 GB RAM / Debian amd64

Change History (4)

comment:1 Changed on Apr 14, 2013 at 11:08:21 PM by Chris Johns

Resolution: fixed
Status: newclosed

Fixed. A check of the permissions is made before any building happens. If --no-install is used the check is not made.

comment:2 Changed on Nov 22, 2014 at 12:29:09 PM by Gedare

Component: CodeRSB
Milestone: 4.11

comment:3 Changed on Nov 23, 2014 at 3:50:06 PM by Gedare

Version: unknown4.11

Set version based on title name, these seem obviously to only affect 4.11

comment:4 Changed on Oct 10, 2017 at 6:04:12 AM by Sebastian Huber

Component: CodeRSB
Note: See TracTickets for help on using tickets.