#2007 closed defect (invalid)

SPARC BSPs: workspace must be aligned on a 8-byte boundary

Reported by: Daniel Hellstrom Owned by: Joel Sherrill
Priority: normal Milestone: 4.11
Component: bsps Version: 4.11
Severity: normal Keywords:
Cc: gedare@… Blocked By:
Blocking:

Description

The linker-script already declares a 8-byte aligned symbol (_end)
which can be used instead of "variable aligned" symbol end.

Could cause bad malloc() initialization.

c/src/lib/libbsp/sparc/shared/bspgetworkarea.c | 5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)

Please see attached patches for 4.10 and HEAD.

Attachments (2)

0003-SPARC-BSPs-workspace-must-be-aligned_HEAD.patch (917 bytes) - added by Daniel Hellstrom on Feb 2, 2012 at 2:03:53 PM.
HEAD patch
0003-SPARC-BSPs-workspace-must-be-aligned_4_10.patch (928 bytes) - added by Daniel Hellstrom on Feb 2, 2012 at 2:07:52 PM.
4.10 patch

Download all attachments as: .zip

Change History (5)

Changed on Feb 2, 2012 at 2:03:53 PM by Daniel Hellstrom

HEAD patch

Changed on Feb 2, 2012 at 2:07:52 PM by Daniel Hellstrom

4.10 patch

comment:1 Changed on Feb 2, 2012 at 2:27:54 PM by Gedare Bloom

Cc: Gedare Bloom added

comment:2 Changed on Feb 2, 2012 at 3:09:31 PM by Gedare Bloom

Resolution: invalid
Status: newclosed

Marking as invalid. At least for head and 4.10.2 this is not a bug.

comment:3 Changed on Nov 24, 2014 at 6:58:28 PM by Gedare Bloom

Version: HEAD4.11

Replace Version=HEAD with Version=4.11 for the tickets with Milestone >= 4.11

Note: See TracTickets for help on using tickets.