#1939 closed defect (fixed)

ratemonperiod.c: incompatible pointer

Reported by: Ralf Corsepius Owned by: Joel Sherrill
Priority: normal Milestone: 4.11
Component: score Version: 4.11
Severity: critical Keywords:
Cc: sebastian.huber@…, gedare@… Blocked By:
Blocking:

Description

Something seems seriously bugged with timespec handling:

Building for almost all targets/bsp currently raises these warnings.

../../../../../../c/src/../../cpukit/rtems/src/ratemonperiod.c:141:7: warning: passing argument 1 of '_Timespec_Subtract' from incompatible pointer type
../../../../../../c/src/../../cpukit/rtems/src/ratemonperiod.c:141:7: warning: passing argument 2 of '_Timespec_Subtract' from incompatible pointer type
../../../../../../c/src/../../cpukit/rtems/src/ratemonperiod.c:143:7: warning: passing argument 1 of '_Timespec_Add_to' from incompatible pointer type

I've tried to investigate, but have given up for now, because the cause is obfuscated by what I consider to be overly use of defines.

Change History (4)

comment:1 Changed on Oct 18, 2011 at 1:38:14 PM by Gedare Bloom

Cc: giddyup44@… added

comment:2 Changed on Oct 18, 2011 at 2:01:28 PM by Sebastian Huber

Cc: Sebastian Huber added

comment:3 Changed on Oct 19, 2011 at 6:38:57 AM by Sebastian Huber

Resolution: fixed
Status: newclosed

I fixed the type mismatch in the CVS. I found no other warnings related to _Timespec_* functions.

comment:4 Changed on Nov 24, 2014 at 6:58:28 PM by Gedare Bloom

Version: HEAD4.11

Replace Version=HEAD with Version=4.11 for the tickets with Milestone >= 4.11

Note: See TracTickets for help on using tickets.