#1764 closed defect (invalid)

RTEMS shell not always waiting for termination

Reported by: dufault Owned by: Chris Johns
Priority: normal Milestone: 4.11
Component: shell Version: 4.11
Severity: normal Keywords:
Cc: joel.sherrill@…, gedare@… Blocked By:
Blocking:

Description

Sometimes two shells startup at the console and they get every other character of input. Observe, this is after a reset:

RTEMS SHELL (Ver.1.0-FRC):/dev/console. Mar 11 2011. 'help' to list commands.
/ #
RTEMS SHELL (Ver.1.0-FRC):/dev/console. Mar 11 2011. 'help' to list commands.
/ # eecchhoo 121212
111
/ #
222
/ #
/ # ttaasskk

ID NAME PRI STATE MODES EVENTS WAITID WAITARG NOTES


0a010001 ntwk 100 READY P:T:nA NONE 1a01000b 0x210a28a8
0a010002 DCrx 100 Wevnt P:T:nA NONE 1a01000b 0x210a28a8
0a010003 DCtx 100 Wevnt P:T:nA NONE 1a01000b 0x210a28a8
0a010004 TNTD 100 Wevnt P:T:nA NONE 55655191 0x210a28a8
0a010005 RPCd 100 Wevnt P:T:nA NONE 1fb05ea2 0x210a28a8
0a010006 SHLC 100 READY P:T:nA NONE 1a010004 0x210a28a8
0a010007 SHLC 100 READY P:T:nA NONE 1a010004 0x210a28a8

I start the shell up like this, so it shouldn't return until it terminates:

while(1) {

rtems_shell_init(

"SHLC", /* task name */
RTEMS_MINIMUM_STACK_SIZE * 16, /* task stack size */
100, /* task priority */
"/dev/console", /* device name */
false, /* run forever */
true, /* wait for shell to terminate */
0 /* login check function,

  • use NULL to disable
  • login check */

);

This is a problem because I typically start my applications with a shell with an optional startup file, and when this happens my application doesn't start right, and it sometimes fails in the field. It happens very rarely. This is happening in 4.11, but it also happened in 4.10.

I know this isn't much to go on, I'll try to watch for more clues.

Change History (3)

comment:1 Changed on Apr 11, 2014 at 6:53:41 PM by Gedare Bloom

Cc: Gedare Bloom added

comment:2 Changed on Apr 11, 2014 at 7:03:12 PM by dufault

Resolution: invalid
Status: newclosed

I haven't seen this in a long time. I'd like to close it not reproducible but don't see that, I'll choose INVALID.

comment:3 Changed on Nov 24, 2014 at 6:58:28 PM by Gedare Bloom

Version: HEAD4.11

Replace Version=HEAD with Version=4.11 for the tickets with Milestone >= 4.11

Note: See TracTickets for help on using tickets.